Cannot upload images larger than 1mb using $_POST


#1

I’m using normal hosting (not VPS).

I’ve followed the steps to create a phprc file and put custom variables in there:

log_errors = 1
error_log = /home/osaahm/php.log
upload_max_filesize = 64M
post_max_size= 64M
max_execution_time = 500
max_input_time = 500
memory_limit = 128M

I am certain the above code works as my phpinfo() file shows allthe variables set as I want them to be. (phpinfo() file can be found at http://thoughttt.com/media/phpinfo.php).

However, whenever I use $_POST to try and upload images larger than 1mb, I recieve a 413 error. The largest file I’ve successfully uploaded in 716kb, though I don’t know any sizes of the failed ones.

All files are .jpg.

I’ve spent a long time trying to fix this, contacted support and done all sorts of things.

I don’t know what to do! :frowning:


#2

I’m having a similar problem, but with Python rather than PHP. Did you ever figure out a solution?


#3

Figured it out: disable “extra web security” in the web panel.


#4

it seems like this is the same topic as https :confused: /stackoverflow.com/questions/22436571/post-cannot-upload-images-larger-than-1mb
-raksha


https://discord.software/ https://adobereader.onl/


#5

Please stop necromancing old threads.


#6