Cannot SSH for the first time


#1

I am trying to SSH to my site that I created in the panal by adding a dreamhosters subdomain. I am getting an error that I am not allowed to SSH. The program I signed up for said it had Shell access. What am I doing wrong?

I type: (replace xxx with my name)
ssh xxx@xxx.dreamhosters.com

I get:
This account allows only ftp connections.

Connection to xxx.dreamhosters.com closed.


#2

This is quite a common issue, but thankfully very easy to solve :slight_smile:

You just need to enable Shell access for that particular user. You do this in the panel at Users -> Manage Users then click Edit next to the appropriate user. You should then see the option to Enable ssh/telnet?

It may take a little while for the change to take effect.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )


#3

DUH!
i feel stupid
Thanks for the help


#4

[quote]DUH!
i feel stupid[/quote]
Dont, as I said in my previous post, that particular issue has caught quite a few :slight_smile:

I guess having SSH disabled by default for users is good security practice.

No problem, I am glad I could help.

Mark


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for promo code details )