Cannot see my swf


#1

i’ve put the swf up on the ftp…then placed the html in notepad and named it index.html and now nothing loads on the website!! someone please help!!!


#2

uh?

You uploaded a shockwave file and then created an index.html file. Okay. Everything sounds normal here. What broke?


yerba# rm -rf /etc
yerba#


#3

In your index.html file did you have something like this (only a different swf file in the two portions :slight_smile: )


Norm

Opinions are my own views and not the views of DreamHost. :open_mouth:
Any advice offered by me should be acted upon at your own risk.


#4

How to embed Flash (and other things).


Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]


#5

I’d recommend against the embed tag, since it isn’t XHTML compliant and was made by Netscape.

-G-

Check out Gordaen’s Knowledge, the blog, and the MR2 page.


#6

Yes I agree about the embed tag. I was going to take it out before I pasted it but it was all I had to hand from my test site, and I was in a rush.


Norm

Opinions are my own views and not the views of DreamHost. :open_mouth:
Any advice offered by me should be acted upon at your own risk.


#7

Fair enough :slight_smile: When strictly using the object tag, IE can have difficulty streaming, so one solution is a container movie, but that’s starting to get a bit ahead.

Have you tried to access the swf directly from your browser (like http://www.domain.com/coolmovie.swf)? If that works, then all you need to add is something like this:

That’s pretty much the bare minimum, if I remember correctly. Anyone know if you can use styles rather than attributes for setting the sizes on object tags? (and whether browsers will pay attention?)

Check out Gordaen’s Knowledge, the blog, and the MR2 page.


#8

Did you not see my link above? All of the examples will work in any browser.


Simon Jessey | Keystone Websites
Save $97 on yearly plans with promo code [color=#CC0000]SCJESSEY97[/color]