Cannot log in to mysql.themodernist.com


#1

Hi, I created the database and user and pw, but when I try to access mysql.themodernist.com (my domain), it pops up asking for a username and password. I use the one I created w/ my database, but it says “access denied.”

How do I access this?


#2

Are you trying to access the database directly from your remote IP address? If so, you will need to whitelist the IP address for that user. Goto MySql databases in the panel https://panel.dreamhost.com/index.cgi?tree=goodies.mysql& and click the user name associated with the database, this will allow you to edit the user. You will see a box showing “Allowable hosts” a default entry for all machine inside the dreamhost network.


#3

Thank you for the response. I am just trying to access the database however I can. I want to check the “import” settings to see how I should try and export a database off my old server. I thought phpMyAdmin was my best shot at this, and that I should access that through mysql.themodernist.com; except then I have this login problem.

I see the area you are talking about but am not quite sure what to do. Please see attached photo.

[URL=http://imageshack.us/photo/my-images/199/picture1tlz.png/][/URL]

Right now “%.dreamhost.com” is the box. I tried adding my IP address but that didn’t work.

What do I change to get this working?


#4

If your simply using the phpMyAdmin link in the panel you should be able to log in using the user/pass without adding an IP in the box.

If you are trying to access it remotely at your own computer (not via the web interface) you will need to add your local IP.


#5

hmm, i just don’t get it.

database: mainmodernist
username: lkjj
password:

I added my IP, and tried the link direct. I enter username lkjj and the pw and I get access denied.

There seem to be so few elements to this, I am not sure what can be going wrong.


#6

Don’t connect via the hostname, use the phpMyAdmin link in the panel.


#7

The hostname should work fine. That’s where the panel points you anyway.

I was able to get into your phpMyAdmin just fine when I tried (after looking up the password). Check to make sure you have the password correct.


#8

Weird, I tried so many times and I am 100% sure I was typing that password correct. Anyway, I tried just now and it worked for me too. Maybe DNS propagate? I have no idea. Anyway, it works, thank you.