Cannot launch instance with new volume

dreamcompute

#1

I can’t launch an instance using “Boot from image (creates a new volume)” option, with CentOS 7. I get the error:

Error: Failed to launch instance “web1”: Please try again later [Error: Block Device Mapping is Invalid.].

I can launch from images using ephemeral disk, but now trying to use block storage instead.

Appreciate any assistance. Thanks! :slight_smile:


#2

Ok, following up with some findings.

If I create a new volume from an image (e.g. CentOS-7.0), then launch a new instance using “Boot from an existing volume”, this works fine.

This probably achieves the same result as “Boot from image (creates a new volume)”.


#3

Give it another try now. It looks like Cinder got “stuck” even though it appeared to be working normally.


#4

Yup, works now, thanks! :slight_smile:


#5

I’m having same issue right now trying to startup new Ubuntu 16.04 instances:

Error: Failed to perform requested operation on instance “attikdoor”, the instance has an error status: Please try again later [Error: Build of instance d7bb7da6-8f87-420b-9545-1c7d2e1dd5d4 aborted: Block Device Mapping is Invalid.].


#6

@drweb: this may be a temporary glitch in Cinder (the volume service). If the issue persists, I suggest you open a ticket and have the issue investigated.