Cannot install Moodle 2.0

apps

#1

I’ve tried this on three different domains hosted with Dreamhost. I must be doing something wrong, so someone point out to me what it is.

I’ve followed the instructions on Moodle’s page for installing via CVS. I set the domain to PHP 5.3 Fast CGI, make a MySQL database, then download the moodle files via CVS.

When everything is ready, I navigate to the page and go through the options, enter database name, hostname, etc.

All seems good to go, but when I hit “Install” it waits a few minutes, then gives me a 500 INTERNAL SERVER ERROR. if I go back to the moodle page, all I get is “A TOP LEVEL COURSE COULD NOT BE FOUND”.

That’s it. Same thing happens on every domain. What am I doing wrong?

Thanks.


#2

I ran into similar problems installing Moodle2.0 at Dreamhost. I was able to get some success by installing via the command line: http://docs.moodle.org/en/Administration_via_command_line


#3

I am new to this, so please take my advice with a grain of salt. I could not figure out how to do cvs, so I downloaded the 2.0.2+ standard .tgz package to my iMac, double clicked to unpack it, and used ftp to copy the contents of the moodle folder to the root level of my domain.

I created a MySQL database with a user name and password first, then called http://www.mydomain.com (if you copy the whole moodle folder you will need to add/moodle/ or change the settings for your domain) to see what I would get. I got a page to start the process and followed the instructions. It was relatively painless and worked fine.

I have a standard hosting plan and it runs pretty slow compared to running it in MAMP locally. I assume it needs to be run on a dedicated machine when it gets busy, but have seen no advice on how many users it can handle before needing it. MAMP is very cool by the way- one click to run it and it is completely self contained.

I suggest at least trying the direct download method like I did.


#4

MPenguin - did you ever manage the CVS install? I’m trying to do the same thing and running into the exact issues.

cptvitamin - how do you do the common line install on shared hosting? I assume you are running VPS or something. I’ve got the old regular shared hosting and am struggling…

tomwootton - I’ll try the direct download method once this fails, but I want to get CVS up so it’ll be easier to upgrade and patch in the future.

Thanks, any help appreciated!


#5

A shared hosting user can either be configured as “FTP” or “Shell”. If your user is configured at as “shell” user then you can use a terminal client such as ‘Putty’ to access the command line.


#6

I’ve been trying things for the last two days with no luck.

•Fresh download of 2.0x with CVS (unsuccessful install)
•Fresh download of 2.1x with CVS (unsuccessful install)
•Fresh download of 1.9 with CVS (successful install) and then upgrading (unsuccessful upgrade) to either 2.0x or 2.1x with CVS
•Fresh download of 2.1x with CVS and then command line installation via SSH (unsuccessful install)

In each case I’m starting with a blank subdomain directory and a database with no tables. The domain is running PHP 5.3 FastCGI

In each attempt at installing with the web browser I get past the server check. Importantly, perhaps, it says I’m running PHP 5.3. But at the point of upgrading modules I get the 500 Internal Server Error just like the OP.

During the Command Line install after the database setup I get:

[code]== Environment ==
!! php !!
version 5.3.2 is required and you are running 5.2.17

!! php_extension zip !!
must be installed and enabled

The Zip PHP extension is now required by Moodle, info-ZIP binaries or
PclZip library are not used anymore.[/code]

That seems odd, doesn’t it? The DH web panel says I’m running 5.3 and the web browser install method does as well.

Well either way, I’m worn out. Unless someone has any ideas Moodle 2 on DH has defeated me.


#7

I’ve more or less given up, too. Nothing seems to work, despite the Wiki saying it should.
Now, I’m also getting FTP authentication errors, so I can’t even upload the files. I’ll be making another post about that.


#8

Hi… I am having the same issue…

Does anyone has the solution for this???

thx


#9

Here’s what I did to get Moodle 2.4 (beta) working on my Dreamhost shared account: https://discussion.dreamhost.com/thread-136444.html