Cannot connect via SSH

dreamcompute

#1

Hello! I just created by DreamCompute account today, and am having problems getting able to connect to instances that I start up and bind to my floating IP. I have followed the instructions in the getting started guide (http://wiki.dreamhost.com/DreamCompute_Getting_Started) multiple times, I tried creating my own security group that specifically allowed SSH only, but no matter what I do, I cannot get an SSH connection to even start opening to the point of doing the security check. This is what I get when I try to connect:

$ ssh -v -v (ip)
OpenSSH_6.2p2, OSSLShim 0.9.8r 8 Dec 2011
debug1: Reading configuration data /Users/(user)/.ssh/config
debug1: Reading configuration data /etc/ssh_config
debug1: /etc/ssh_config line 20: Applying options for *
debug1: /etc/ssh_config line 102: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to (ip) [(ip)] port 22.
debug1: connect to address (ip) port 22: Operation timed out
ssh: connect to host (ip) port 22: Operation timed out

Using this same terminal window, I am able to SSH to my VPS just fine, using the same public key that I have configured in my DreamCompute:

$ ssh (user)@(host).dreamhostps.com
Linux (host) 2.6.38.8-2-vs2.3.0.37-rc17-blkio #20 SMP Thu Aug 4 11:28:54 PDT 2011 x86_64

The programs included with the Debian GNU/Linux (host) are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux (host) with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Wed Mar 11 14:10:18 2015 from (my_ip)
[(host)]$

Thank you for any help you can provide!
[hr]
Well, nevermind I guess, because somehow it has fixed itself and is now working without any problems.

Thanks for your time anyway!


#2

I think I just answered your ticket. I tried to ssh to the provided ip and it was showing the proper permission denied (publickey) error. Please let me know if you still see issues and if you have a way I can reproduce it.


#3

Yes, you did, and as I replied above in a quick-reply, the problem appears to be rectified now. Thank you for your time!