Cannot connect to phpMyAdmin from DreamhostPS


#1

I have tried to connect to phpMyAdmin from the Dreamhost website. However, I cannot seem to log in, and my website is down.

I get the error: #1130 - Host ‘ps9331.dreamhost.com’ is not allowed to connect to this MySQL server

I am on DreamhostPS servers, and I tried rebooting the servers, but it does not help.

I cannot log in to change my MySQL databases or even log into my own website. I will get an error message:
Warning: mysql_connect() [function.mysql-connect]: Host ‘ps9331.dreamhost.com’ is not allowed to connect to this MySQL server in /home/…/index.php on line 11

What is wrong, and how can I rectify it? I need the server to be up urgently.

Thanks in advance for any help that can be provided.


#2

Check that the Allowable Hosts is filled in correctly.

[color=#00CC00]Panel > Goodies > MySQL Databases[/color]

  • Click the [color=#0000CC]Users with Access[/color] (user) link next to the troubled database.

  • Scroll down to the Allowable Hosts editable field.

  • Ensure it contains %.dreamhost.com (and that appropriate permissions above are set).

  • Click [color=#0000CC]Modify [dbname] now![/color]

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost


#3

Thank you very much!


#4

I’m having a similar problem. When I click on the phpMyAdmin link on the DH Web Panel page, it redirects me to:

http://www.mydomain.com/dh_phpmyadmin/mysql.mydomain.com/

and I get a message ‘The page you were looking for doesn’t exist’

My user settings match what is described above in the allowable hosts field. I even tried adding ‘mysql.mydomain.com’ but that didn’t work either


#5

That looks a bit like an internal lookup problem.

You could try adding another SQL Hostname and connecting to that.

[color=#00CC00]Panel > Goodies > MySQL Databases[/color]

  • Click [color=#0000CC]Add New Hostname[/color]

Maximum Cash Discount on any plan with MAXCASH

How To Install PHP.INI / ionCube on DreamHost