Cannot cancel a folder


#1

Hi,
I’ve installed an application with “first click install” into a newly created subdirectory on my site.
Now I want to completely delete that folder. After connected with my ftp client (Total Commander) I cannot eliminate all files/folders. Why ?


#2

Did you add the hotlinking feture to this folder?

You can eliminate your folders through Dreamhosts’ FTP:

http://webftp.dreamhost.com


#3

by default many FTP clients will not let you delte folders what have files in them, or some won’t let you delete folders with hidden files in them. You should be able to find a setting in your FTP client ot show hidden files and holders, and to allow you to delete ‘full’ directories.

If you’re having trouble finding this setting you may want to tell us what FTP client you’re using and then someone else may be able to tell you exactly how to do this.

As mentioned above, I believe you can also use DH’s webftp service to delete that directory.

–Matttail
art.googlies.net - personal website


#4

You know, I’m running into the same dilemma right now myself.

I’ve tried to chmod, I’ve tried rm -r on the directory in shell, and rmdir etc…all to no avail.

Trying to get rid of zencart. I’ll post back if I get it figured out. Agh!


#5

Did you do it with a 1 click install? If so, use it to remove it.

Or, chown


#6

Hey ModWriter,

I did do it with 1 click install. What’s funny is…I did use it to remove it, but for some reason it didn’t and just left it in there.

So I went in and tried from your idea to do “chown myusername filename” on the file that was holding up the zencart folder from being deleted. It tells me:

chown: changing ownership of `mysql_upgrade_zencart_110_to_112.sql’: Operation not permitted"

So I’m again out of ideas. What do you think?

Anyone else have this problem and solve it? I’d hate to bug DreamHost about this right with the sluggish server hell and other issues at the present moment.


#7

i have the same problem. what I did was I renamed the folder to ‘dead’ and just let it be. i will deal with it later, but now, i need to install some things. really annoying, that for some reason, there is no option to sudo rm it.