Can I increase the SQL max file size?


#1

Currently the max size is set to 7,168KiB and I need it to be at least 8. How can I do that? Thanks


#2

Are you referring to the maximum import size in phpMyAdmin? If so, you’ll need to use other methods to import large backups. See http://wiki.dreamhost.com/Migrate_MySQL for details.


#3

Thanks for the info.


#4

I am interested in this as well, on that page i would like to ask if this is a typo?
mysql -h mysql.example.com -u username -ppassword dbname < outfile.sql

the -ppassword should that be -p password ?


#5

No, actually. All the single-character options to the mysql command can be “nestled” with their arguments (e.g, -hhostname), and doing so is in fact mandatory for -p.

If that gnaws at your conscience, you can use the more verbose form:

But that’s just more typing for no real benefit. :slight_smile:


#6

You can also just type -p and it will prompt you for the password. That way your password won’t be visible to others should they look in /proc. I’m not exactly sure how that works or whether it’s really possible or not, but I started using the bare -p switch some time back because of warnings about it in the mysql documentation.


#7

Not necessary, actually. We have things set up so that users can’t see each other’s processes, either in ps/top or in /proc.