Can I force my site to refresh for changes?


#1

I made a minor change to nine pages on my site the other day (updating copyright notice among other things) and on three of the pages the changes have not been reflected. I use Dreamweaver, and retrieved the new pages which I had ‘Put’ to the site, and the updated files are correct with all of my changes.

Is there a way for me to force the site to refresh at the Dreamhost end? I refreshed my own machine, deleted cache, etc, and tried on another device. I waited overnight and the three pages still have not reflected the change.

This happened once before and I ended up renaming some pages to force the changes that way, but I know that is a silly solution. I want to know if there is a way for me to trigger an update at my end.

Thanks.


#2

It sounds as if a website caching mechanism is hindering your ability to view the new data immediately. Are you using a CMS with inbuilt or “plug-in” caching?


#3

I assume you’ve tried to clear the caches on the server.

If you are on VPS, you can reboot the server. You can’t reboot apache on a shared server though.

If you are using a caching plug-in as sXi mentioned, the plug-in should have an option for you to refresh all caches.


#4

I’m afraid I’m just a basic user who has had my site hosted by Dreamhost for a number of years.

How can I find out where to clear the cache on the server? Is there an action to trigger from the control panel?


#5

It sounds like your site is just static HTML (generated by Dreamweaver), so there’s no caches to clear on the server. If some of your pages haven’t updated, you may want to check in Dreamweaver to make sure those pages are still part of your site, and that there isn’t anything unusual about them that would make them not receive your updates.


#6

It is odd. There doesn’t appear to be any issue with the pages, and as far as I can tell I ‘Put’ the updated pages on the site (or so says the file when I retrieve it from the Remote Site.

I deleted the pages in question, but I don’t get an error when I navigate to them. I was hoping to remove them and just put them back again. This happened once before with my last updates.

Will take another look, but I can’t see that there is anything wrong.
[hr]
Hmmm. All set now.

I checked out the files manually using plain FTP in Windows Explorer and confirmed the correct files were on the site, and now everything seems to be okay. Maybe it was my local cache afterall, in which case I may feel a bit silly.

Thanks for all the advise and suggestions!


#7

Could it be that DW is set up to place the files in a different userspace? Might pay to check which user it is logging in as.

I only mention this as I’ve been caught out with something similar myself. Editing files in a dev.domain and wondering why I wasn’t seeing changes in a browser session – only to discover I was refreshing the live domain and not the actual place I was working. Doh! :smiley:


#8

Will take another look. Thanks for the suggestion.