Can GIMP be installed on a VPS?


#1

Hello DreamHostees!

I’m trying to do some magic tricks with GIMP and I’d like to install it on my VPS. I’m attempting to run the command below:

apt-get install gimp

When I do, I get:

E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

Does this mean I can’t do it, or do I need to do it some other way?

(BTW, my main goal is to be able to run xcfinfo and xcf2png, so I may be on the wrong path to begin with. According to http://manpages.ubuntu.com/manpages/natty/man1/xcfinfo.1.html, I believe I need to install those tools from here: https://launchpad.net/ubuntu/natty/+package/xcftools)

I’m a huge Linux newbie, so any help would be appreciated. I know just enough not to rm -rf / my entire system. :slight_smile:

Anthony Gill
Goblin Workshop Games
www.goblinworkshopgames.com
Print On-Demand Services and More for Game Designers


#2

Create an admin user on your VPS, if you haven’t already, then run the apt-get via “sudo” (“sudo apt-get install gimp”) from that user. FWIW, you can probably skip a step by just installing xcftools directly (“sudo apt-get install xcftools”), which doesn’t actually depend on gimp being installed.


#3

You, sir, are my new best friend. It worked like a charm! I installed GIMP just for good measure as well, since I may need gimp scripting.

Thanks for the quick reply!

Anthony Gill
Goblin Workshop Games
http://www.goblinworkshopgames.com
Print On-Demand Services and More for Game Designers[hr]

Ok, I thought I was done but apparently I’m not. So I’ve installed xcftools, but I don’t seem to be able to run xcfinfo. Now that it is installed, do I need to do anything else?


#4

You shouldn’t have to. Everything I see on http://www.debian.org/distrib/packages says that xcftools should include xcfinfo. I checked your VPS real quick, and xcfinfo seemed to be installed and working, so I’m not sure what could be wrong… can you give some more details?


#5

Hmm… well, I first tried running “xcfinfo” as my admin and had no results, so I switched to a normal user. A copy and paste from putty is below:

[font=Courier]login as: *********
goblingames@www.goblinworkshopgames.com’s password: *****
_ _
| |___ _ | | ___ _ __
| / / || (-< / _ \ ’
|
_\
,/_/_
___/||_|

Welcome to kustom.dreamhost.com

Any malicious and/or unauthorized activity is strictly forbidden.
All activity may be logged by DreamHost Web Hosting.

Last login: Mon Jun 6 15:48:46 2011 from office.distribion.com
kustom:~> xcfinfo
xcfinfo: Command not found.
[/font]

I’m not sure what to do beyond this…?


#6

The machine you’re logging into (kustom) is not the VPS you installed xcfinfo onto. You’ll need to move your domain to the VPS to use the software you installed on it.


#7

That’s interesting…

Ok, so the admin account was created on ps52498. Does this mean that ps52498 is my VPS server, and kustom is just a regular server and I’ve been thinking I’ve been using a VPS all this time? :slight_smile: If so, I have a lot of migrating to do…[hr]
Actually, I think I found the answer to my question - yes, kustom is a shared server and ps52498 is my private VPS. I thought that enabling a VPS automatically transfered everything from the shared server to the private server. At least that is how I interpreted it.

I’ll try migrating everything over to the VPS and hopefully that should take care of things. Thanks for your help!