CalemEAM install

apps

#1

I am writing to see if anyone’s looked at CalemEAM for asset management and purchase management. It’s still in beta but looks rather nice.
http://www.calemeam.com/

I’d like to be able to install it on DH but haven’t been able to get by the env.sh file configuration. I set my HOME as my home directory on DH and PHP where PHP lives, etc…

Any help at all would be greatly appreciated.


#2

I downloaded and installed the system following the configuration guide on their website. I was able to get it started on an XP system with no problems and used the WAMP install. What in particular did you get stuck on in the env.sh?


#3

#!/bin/bash

HOME_DIR=/home/.maka/username/
PHP_EXE=$HOME_DIR/usr/local/php5
export CALEM_DIR=$HOME_DIR assets.domain.com/calem

The install application expects /usr/local/php5 to be inside my HOME_DIR and that isn’t the case. What did you use as your HOME_DIR?


#4

On windows xp I used the defaults:

set HOME_DIR=c:\wamp
set PHP_EXE=%HOME_DIR%\php\php.exe
set CALEM_DIR=%HOME_DIR%\www\CalemEAM\


#5

If I had php installed in my home directory then I suppose it could work but DH doesn’t like us to do it. I don’t know as I wanted to test Calem and don’t know if it’s worth doing all this work for.


#6

It also seems to me that even though it’s compatible with Linux that it was built for WAMP as a normal Linux install isn’t configured that way.


#7

For a setup on Fedora 6 we have the following evn.sh

HOME_DIR=/opt/lampp
PHP_EXE=$HOME_DIR/bin/php
CALEM_HOME=$HOME_DIR/htdocs/CalemEAM
export CALEM_DIR=$CALEM_HOME

You’re right in that the current installation guide is for Windows. A new release with a few changes for Linux will hit SourceForge within a week or so (for instance, a PHP version for jsmin.exe). Additionally, online demo will also be made available soon.


#8

Hello Clay,

Thanks again for your responses! I’ll wait to see what you’ve got in the new release.


#9

The release for Linux (r1.0.1x) is available on SourceForge.net. The demo is also released, check it out at http://www.calemeam.com. Let us know your feedback.


#10

Did you ever get CalemEAM to work?

I have installed the latest version (v2) and got env.sh to work (shown below) and the database updated, but when I tried to hit the front page for the first time, I got “500 Internal Server Error” problems. After looking at the logs, I think it is because PHP is running in CGI mode.

Here’s my env.sh that worked:
HOME_DIR=/usr/local/php5
PHP_EXE=$HOME_DIR/bin/php
CALEM_HOME=/home/.orji///CaleamEAM
export CALEM_DIR=$CALEM_HOME/

Cheers,
Sean.


#11

I gave up after discovering that it doesn’t do what I was hoping it would do… good luck