Buddypress, WordPress, Emails to Comcast users blocked

I set-up a new WordPress site and installed BuddyPress and bbpress. None of my testers with comcast.net email addresses are able to register and do not receive email notifications. Users with gmail addresses work perfectly fine. I installed WP email Bank to try and set-up emailing using a gmail address but I can’t seem to get the settings right to send email from the site. Anyone solved this issue before? Is Dreamhost unblocked by Comcast yet? Is there another plugin or function that I can install or add to resolve this?

Hi buddy. I think your first approach here would be to contact Comcast and verify if the email really hits their servers and being blocked.

Once you’ve confirmed this and know why it’s blocked, then you would probably know the next step that you should do. Below is an old post but I think this is still ongoing.


Obviously you have never contacted Comcast… :wink:

On the Comcast side, there are a number of help pages and self help tools related to Comcast email located at http://postmaster.comcast.net/ (Most of Comcast’s level 1 front line call-takers don’t even know those pages exist, they will instead send you an email and when you receive that email they will tell you your email is working therefor there is nothing they can do about the email that you think is missing or blocked.)

On the Dreamhost side, It’s my opinion that dreamhost does a better job on the subject of email than it did a few years ago, BUT even though they have made gains they were in a deep hole when they started trying to get a better handle on spam and mail blocks and still haven’t reached the surface. The fact is, Dreamhost shared web servers do get regularly blocked for spam. The simplest thing that users can do to help themselves is to configure their web applications to not directly send the email from the webserver (i.e. php’s mail() ). Instead, configure to send from a valid email account that exists on the mailserver. (Dreamhost separates webservers and mailservers). The method to do this depends by webapp, in general, you will need to specify “use SMTP”, “Send via SMTP”, etc. You will need to specify an smtp server which should be mail.example.com (your domain name of course), and you will need to supply credentials to log in to an account (i.e. a mail user/mailbox created on the “manage email” page of the dreamhost panel.) Dreamhost’s email servers don’t end up getting blocked nearly as often as the webservers, so using smtp settings to originate email from a mail server will improve reliability.

“Dreamhost” as a whole is not blocked by comcast. (I tested to confirm) If you have not opened a ticket on this, do so. This ensures the abuse team knows about the block. They won’t update you on specific blocks, reporting them however is still important to getting them removed.

Additionally configuring for smtp as noted above will most likely solve your problem.

Is the e-mail being sent directly from a shared dreamhost server? I’ve noticed some providers will block mail from those hosts. You will do better by configuring WordPress to send via an SMTP Smarthost. ie. create a mailbox account specifically for WordPress to authenticate against to send e-mail and configure that server and credentials for mail sending. That way the mail arrives at comcast from DreamHost’s actual mail servers, and not from a web server with a lower reputation.

This is the plugin I use to get wordpress to send using an SMTP server with Authentication: https://wordpress.org/plugins/wp-mail-smtp/