Brisk server download speed problems


Has anyone else been having problems with brisks download speeds (to users from the web?)

I started getting widespread complaints that the download speeds had dropped from 600-800’s on average to 15kB-120kB. I was able to duplicate this to a dedicated server at serverbeach and my personal home cable. I used to get very consistant good speeds, now I get the same as the users reporting this. I opened a ticket to support explaining the problem in detail and they asked for some traceroutes for samples. I provided my dedicated server and home traceroutes and all they did was look at my response times and totally discount the rest of the discussion and blamed my ISP. The irony in the situation was that my traceroute response times have been consistant since I got the server from by my dedicated server and my home cable. I find it disturbing I have to start gathering traceroutes from all of my users just try to to make then revisit the issue. Has anyone else had problems?


Which server are you on? Can you provide the URL of a large file we can download as a test?



I am on the ‘brisk’ server. A link to a large file is, I gzipped it up so you can do a direct download:


The problem is spuratic sometimes, almost like network saturation because it gets better at extreme offpeak times. 1-2am CST, etc. Anyways please post your results as I am compiling data on the issue.

EDIT: I just did a quick download to my personal cable and to my dedicated just to see how the current state was:

Cable: 112-120kB/sec
SB Dedicated: 78-82kB/sec


I got sub-150K/sec over a T1. Even from within DreamHost, it’s only about 150-160K/sec.

Since I’m not on the brisk server, maybe you can SSH in to brisk and try:
and see what kind of rate it is there.



I didn’t even think about trying it internally… I tried wgetting it and only got 35kB/sec… hah…


I’m getting 130k/sec from my cable modem and only 23k/sec from my DH server via wget.

It doesn’t look pretty.

Edit: I was able to download a compressed file from my server to my pc at 526k/sec So there’s something strange with your box at DH.



Thanks for the replies, I have been emailing support all the information I have compiled. So far ever sense they looked at my traceroute and disregarded the entire problem they won’t talk to me =/ I guess I shouldn’t have paid for a year.


It’s ironic how “brisk” isn’t.

Maybe you should ask to be moved over to “pokey” and it won’t.



i got 160 kb/s on a t3. cant do a traceroute as my uni is blocking it. i am at work btw. hope that info helps at all.



I finally got a reply today and they said it was something in the apache config. I find it extremely bizzare that they have there apache config somehow limiting traffic. Deffinately would explain how they keep certain users from using there bandwith lol.

Anyway here is the reply I got back:

“We’ve actually now figured out what’s causing this slowdown and have
confirmed that it’s something affection a portion of our users. I’ve just
used that latest information to run another fix on the Apache service
that your domain is hosted on. I tested it again before this fix and got
about 140kbps down, and now I’m able to get a steady 340kbps on multiple
attempts. Please let me know if you’re able to see the same or not.”

I tested just a few ago and got the following:

Download from my personal cable. 110kB/sec
Download from a dedicated server. 105-110kB/sec
Download via lynx from a shell on the brisk server to the apache server (brisk) on the same server and was able to only get 110kB/sec.
Download via wget from a shell on the brisk server to the apache server (brisk) on the same server and was only able to get 35-40kB/sec.


Still slow for me. Since you still have a ticket, send them a reply and let them know how it’s still going.



I sent them some more information. I realized that I was doing all my tests through http/apache. I noticed that my offsite backups that I put on dreamhost were uploading to them at really good speeds. They mentioned the problem to be in apache so I researched some more and it seems they are right. FTP downloads/uploads are not effected. I still dont understand if they ‘don’t restrict bandwith’ why apache would be causing this. Hopefully they get it fixed soon… This is rediculous.


Ok… so… I spend like 3 days getting them to admit there is a problem, 4 days sending them endless amounts of data for them to finally reply with… ‘the fix the other day should have worked, let us know’

Who runs this company? Santas Elves? Amazing…


Yup, I’ve had exactly the same problems (on server “khan”), both with download speeds and Support’s seemingly apathetic response.

I too was able to (eventually) establish that it was apparently an Apache configuration issue, and that a fix had been applied to remedy the problem. Alas, this didn’t seem to make the blindest bit of difference, and download speeds continued to be limited on my main domain.

If it helps, a solution that I stumbled upon was to delete web hosting for the affected domain in the control panel, and then re-apply it immediately afterwards. This appears to “re-allocate” a different version of Apache to that domain, which, if you’re lucky, will circumvent any errors in the configuration of the previous version. Bear in mind that this is likely to take your site off-line for a few hours while the new dns propagates.

A good way of checking which Apache service is serving files for your domain on a particular machine is to see which ip address/hostname your domain points to; this information is also contained in the default dns records in the panel. Since I operate numerous sites, I was able to see that it was a particular ip address (and thus Apache instance) that was causing problems over a couple of domains.

One does have to wonder, however, exactly why Support were being so evasive about this issue. It took me at least 3 support tickets, countless traceroutes and loads of other bits of supporting evidence to get them to even admit there was a problem. And after all that, the “fix” hasn’t made things any better. Maybe, just maybe, the claim that Dreamhost don’t limit transfer speeds isn’t entirely true…


That brings up an interesting point. Perhaps the old Apache version from old sites isn’t as well maintained as the new version used for new installations.

Perhaps the original poster can create a new subdomain and see if that’s any faster, or at least a subdomain.



Well I have only had the account about a month, hold old can my version be? On thate note I have done exactly what you mentioned in regards to the subdomain. It has created it on a seperate apache instance so were gonna see what happens.

I will keep you posted.



Don’t hold out too much hope of this working long-term… I’ve just done another Dreamhost-internal test (via ssh) on a large download on the domain that I thought was fixed, and it’s being limited to 40KB/s now.

For whatever reason, the configuration problems seem to have “spread”, virus-like, to an instance of Apache that definitely wasn’t affected before. I cannot possibly think why this sort of thing would happen.

Support now say they’re trying to pin down the problem definitively, and, understandably given the holiday period, a solution may take a week or so. It’s reassuring to know they’ve got the issue in hand, at the very least…


They fix soon for you. Ask refund if no fix.

For Customers, by Customers, of DreamHost


Yeah they aren’t to ‘open’ on how to get a refund when I asked them. We will see.


I’ve had EXACTLY the same problem.

I’ve reported sub dialup speeds on my account since being moved to a different apache server about a fortnight ago, I was moved because the original one I was one kept crashing.

Since then my speeds have dropped to less than 10k (used to get about 500k !), I have reported this TEN times over the last fortnight to support, and each time I have been told it was fixed, and it never was until about 2 days ago when my speeds returned to 500k, today they are back down to sub dialup.

Dreamhost seem to have a MAJOR problem with this, they don’t seem able to fix it :frowning:

My annual account is up for renewal in a few days and I’ve told them that I’ll charge back my card if this is fixed and then drops back repeatedly again, it makes my whole account pretty much unusable.

Not impressed at all…