Bogus email address spam handling?


#1

I can answer that one… most of the time, they keep coming. Very few spammers pay attention to User Unknown errors.

Another thing to know is that if you have a wildcard, our system doesn’t currently send a real bounce (i.e., a 550 “reject” message during the SMTP process), but rather sends a fake bounce back to the sender. A reject message during the SMTP process is better because it’s more likely (but still unlikely) that a spammer will notice and remove your address – and it’s also not going to send a bounce message to an innocent bystander – but the “fake bounce” will.

I wouldn’t suggest autoforwarding to spamcop unless there’s some sort of confirmation involved… I’m not sure whether or not there is. While it’s unlikely that non-spam will get in your “legitimate” folder, this creates some risk of generating false Spamcop reports. Creating false Spamcop reports is a bad idea because it makes ISPs more likely to take these reports with a grain of salt, and creates extra work for someone. Spamcop makes mistakes often enough that any Spamcop submission should be reviewed by a real person.


#2

[quote]I wouldn’t suggest autoforwarding to spamcop unless there’s
some sort of confirmation involved…

[/quote]

Oh, yes. Please do not ever use a 100% automated system for spam reporting. One thing I noticed when I was handling SpamCop reports is that many of them were reports from customers whose own URLs were mentioned in the body of the email (“we just saw your site at www.blah.com”), and neglected to modify who the report was sent to.

That’s not even the fault of SpamCop, as they tell you to watch out for this. I’m such a nice guy (heh), I’ve never disabled a customer after they reported themselves, but it was rather annoying.

  • Jeff @ DreamHost
  • DH Discussion Forum Admin

#3

Probably you have your e-mail program configured to send mail in HTML format instead of plain text. You should change your configuration to use plain text only.

If you’re using one of the Microsoft abominations (Outhouse, Outhouse Excess), the forwarded message might still not come out the way SpamCop wants… those atrocious programs tend to “munge” both the headers and body of anything that passes through them, like it was eaten up, passed through the program’s digestive tract, then excreted out the other end. You’re best off switching to a more standards-compliant mail client, like Mozilla or Pegasus.

Incidentally, you’re also violating some standards in your postings here… your quotes and apostrophes are the nonstandard Microsoftism characters that are not part of the ISO-8859-1 character encoding (which Dreamhost’s server announces the forum pages to be using), but only in the proprietary Windows-1252 set (which puts these characters in a range that’s reserved for control characters in ISO-8859-1 and in Unicode). Are you typing them in that way, or pasting in your text from some other program?

– Dan