Bogus directory won't go away!


#1

Ok, it’s a minor gripe, but on the offchance somebody else has had this…

In trying to get things set up Just How I Like Them, I changed the default /home/user/site.domain location for my site to /home/user/www/site-domain. Created the directory, can serve from it no problem.

But some process keeps making the empty directory /home/user/site.domain all over again! This is warfare now - I’m going to monitor when the damn thing gets created, and set up a cron job at just the right time of the hour to unlink the critter.

Is there a better way?


#2

Yes, leave it alone. I listen with genuine interest to your reason for wanting to do that. Myself, I see no reason for it.

[color=#0000CC]jason[/color]


#3

The reason is simple, if trivial. :slight_smile:

If I’m going to have several domains on the account, I don’t want loads of directories in the home directory. I’d rather have them all in a subdirectory called ‘www’. It would be a shade easier for me to manage that way. It would also mean the paths match my local machine.

Anyway, it wasn’t essential but the functionality was there on the control panel, so I’ve done it now.

I’d be interested to know if there’s a reason why I should go back to the default settings, and also if this can be considered a bug (albeit a minor one).