Blonde moment


#1

I’m am completely new to the self-hosted blog area. and so, this is likely a very silly question - but how the heck to i get my url to stop appearing as the index of/ and like the actual blog I’ve created in wordpress?


#2

It sounds like you may have WordPress installed in some directory other than you “base” web directory.

Did you use the DreamHost “once-click” installer? If so, what directory did you place the WordPress installation into? Can you provide the url to you site that is evidencing this behavior?

I’m just looking for a place to start helping you troubleshoot this. :wink:

–rlparker


#3

My url is theineptblogger.com.

I did use the one-click wp install and looking at my ftp, I start off with 3 folders: logs, maildir and my url. Under my url, is where wp is installed. Is this the wrong place? Where is my “base” directory, if so?


#4

Yep! That explains all :wink: Your “blog” actually now lives at
http://theineptblogger.com/Wordpress/, instead of at http://theineptblogger.com.

Had you installed your word press in the directory theineptblogger.com, all would be well - you just installed it in the wrong place.

To my thinking, since you have no content entered at this point in the blog, I would just “delete” that “one-click” install, and re-install WordPRess in the /home/yourusername/theineptblogger.com directory, and all should be fine.

There are other ways to do it, and you could even do a redirect from your “base” web directory (/home/yourusername/theineptblogger.com) but that is a “kludge”.

Does that make sense?

–rlparker


#5

I have all my WordPress blogs installed in the base/root directory of my sites. The only problem I’ve had in moving them when I’ve made the same mistake is in not deleting all the files first. For some reason, there are always a few files leftover and the one-click install insists on installing into a totally clean directory.

Ms. Blonde let us know if you have problems and we’ll try to help!

(Forum watchers: I hope this isn’t taken as a me too post, but I thought personal experience with this warranted this amplification)

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#6

okay, so let me get this straight scratches head, my index file is currently in /url/wordpress/ and i want to delete the whole wordpress folder and reinstall it’s contents under /url?

ex: /url/wp-admin…/url/index/php?


#7

i have deleted all of the files ad reinstalled them in the same place, before - template issues.

and actually, they all did get deleted and then uploaded without issue - and yes, it’s annoying that wp decides to go for a clean folder to install to, instead of just what is right (for those of us that assume that clicking ok, is the safe thing to do).


#8

I don’t see that as a “me too” post at all; you brought additional and valuable information to the discussion! :wink:

I often “just move them” myself, but given that doing so requires some edits to paths and makes a “moved” site no longer able to be “automagically updated” by the “one-click” robot, I thought this user might be better served by starting over.

–rlparker


#9
  1. Yes, you want to delete the whole WordPress folder. You actually can do this by doing a one-click delete from the web panel.
  2. Some of your example file paths are a little confusing, but your original statement “my index file is currently in /url/wordpress/ and i want to delete the whole wordpress folder and reinstall it’s contents under /url?” is correct. Mostly, I don’t know what the “/” is between “index” and “php” in “/url/index/php”.

Basically, you want to “move” your installation “up” one directory. However, you don’t want to literally do this because the one-click install system will get screwed up if you do that. So therefore, rlparker suggests you delete the install and reinstall one level up.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#10

Lensman’s got you going the right direction. Note that is is not “WordPress” that cares about being in an
empty" directory…it’s the DH “one-click” robot that “cares”. :wink:

Installing WordPress “manually” makes this a “non-issue”. As for any template related, or permalink related, issues after a “move”, you might want to take a look at the WordPress codex section on “Moving WordPress” for some tips.

–rlparker


#11

That is the general idea, for “moving” an installation, but as I pointed out before, if you do it that way you will lose the ability to upgrade via the "one-click installer.

This isn’t necessarily “bad”, if you are willing to manually do the upgrades yourself (it is not that hard to do). [winkl]

If, however, you do want to rely on the “one-click” robot for upgrading, simply using the Control Panel -> Goodies -> One-Click screens to delete the first install, and them using it again to create a new install in the correct directory will give you the functioning address you desire and preserve the “one-click upgrade” goodness.

I’m sorry if this confused you; I probably could have explained it better :frowning: .

–rlparker


#12

okay, so i jumped the gun and deleted the original wp folder in my url’s directory and uploaded it’s contents to my url’s directory - so basically, I just eliminated the wp parent folder…

now, instead of just index of/ and a wordpress link, I have all of my files showing. rrrrr.

i knew this would be difficult but i will be bald by the time i get it straight!

thanks rl and lensman for your help!

editted: it appears that some files may have not made the reinstall…hey, i figured something out, myself!


#13

The result of that is that your path’s are now messed up, and your WordPress is “functional”, but can’t properly locates it’s templates.

It is still not too late to just delete everything in, and below, your theineptblogger.com directory, so that it is “empty”, and make a new “one-click” install :wink: .

Otherwise, you will need to tweak a few thing as indicated in the “Moving WordPress” document I linked you too earlier, to get things working properly (and you will no longer be able to “one-click” upgrade).

Don’t get discouraged, you are almost “there!” :slight_smile:

–rlparker


#14

thanks.

i’m in the process of redoing the one-touch install - how do i make sure that i don’t end up with it in the same place again?
ex. url/wordpress/ ?

okay - new issue: i cannot empty my folder /url. so therefore i can’t redo the one-click install properly. I’d deleted my dbase, and created a new one…tried the reinstall again. How the heck can I delete everything from my url folder? I keep trying the entire folder, the individual files and nothing will erase…it just keeps reappearing!


#15

In the “Install to” section of the “one-click” form, select only the domain name (/url) as in:

install to: http://www.theineptblogger.com/ <leave this section blank*>

Also, make sure you deleted any “sneaky” hidden .htaccess file that may be left in the /url directory before proceeding! :wink:

–rlparker


#16

yes, see above ^^^ I can’t delete everything using my ftp program. Any suggestions? I renamed the Garbage folder as Wordpress…hoped it might spark the delete function to actually work! :stuck_out_tongue:


#17

Also…don’t forget to delete that “Garbage” directory that is there now…

…ooops! It looks like you have it in the wrong place again, as I am now seeing a WordPress directory once more. :frowning:

–rlparker


#18

Ok…let’s do this a step at a time. First, don’t make any more changes for the moment, ok? It’s kinda hard to hit a moving target :wink:

Sit back, take a break, and tell what ftp client program you are using so I can talk you through the deletion process, ok?

EDIT:
FLASH! Woo Hoo! it looks like you’ve now “done it!” :slight_smile: Cngratulations!

–rlparker


#19

I think…we may have success! (i just created a new /url folder and renamed the old one that had the contents in it that wouldn’t delete)


#20

Yep…that’ll work too! Good Deal, and congratulations! Do you now want to delete the folder that you renamed? IF so, what ftp program are you using?

–rlparker