Blog erased!



Hey guys,

I’ve just encountered a huge problem. Shortly after upgrading my WP to the latest version, my entries disappeared and what makes it worse is that I can’t even log in (apparently it even screwed my details). I know it’s still around only because its backup is still visible. I’ve tried replacing those old files into the root directory, but nothing has worked. REALLY FRUSTRATING. Would really appreciate some assistance.


My blog is at, old one is at


First of all, what version of WordPress were you using before the back up? I only ask because of the potential for database structure changes.

If you have not modified the database as part of the upgrade, and you have not deleted any files from the “old” subdirectory and its sub directories, you should be able to:

  1. delete everything from your directory

  2. Copy everything (including .htaccess file(s), and everything in every subdirectory of from the directory to the directory.

These steps should put your blog back “where it was”.



My last upgrade was in Jan, and there was an error already then, which I managed to fix it - was a Tag Warrior issue.

I’m very sure I just used the one-click install, so the db was definitely not touched.

Question, how can I delete everything from the parent directory, when even the old folder is a child under there too?



Ok, I looked at the source pf your “index” page, and see that your old version was 2.01 (released over 2 years ago!) - there have been database changes since then.

This means that since you updated the application, you have probably also updated the database (if you followed the one-click success email instructions), and this means the databases are no longer compatible between the “old code” and the new upgrade.

There are a few ways to deal with this …

If your content is important to you, and I assume it is, I think the best approach to take is to try to get your blog back to the way it was, and then develop an upgrade strategy.

To do this, in addition to the steps I described in my first response, you need to “retrieve” and “old” copy of your database from before the upgrade attempt.

You should be able to do this via the Web Panel -> Goodies -> Manage MySQL screen by clicking the “Restore DB” link under the “Actions” column of the database your WordPress installation is using.

Once you have done that, and replaced the “old” files/directories over the “new”, your blog should be back where it was.

It is often problematic to upgrade “skipping” numerous intermediate upgrades, as there are often intermediate changes and “upgrade scripts” may not always catch all the differences (they often assume you are upgrading from a recent version).

My advice is to get your blog working again, and then investigate whether or not you need to do some intermediate upgrades to get yourself current. You will probably have to do this “manually” at this point (since you let your blog get so out of date version wise), but that can be done. :wink:



That is very confusing, since your “old” blog clearly identifies itself as:

…which, as I said in my other post, was released in January … of 2006! :wink:

Even using the one-click installs, the database should have been “touched” several times since 2.01 - the one-click installer is now installing version 2.3.3, and there have been database changes since 2.0.x.

Part of the “upgrade” process is usually a WordPress routine to update your database that you are askied to run after the upgrade. DId you do this after the “January” upgrade, and after this last upgrade? :wink:

There are a couple of ways to go:

  1. Use the shell to create some other directory in my user directory (the same directory that is in) and “move” (mv) the directory there, for safe keeping, and then delete’s contents

  2. Even better, just rename to something else ( and create a new (now empty) directory

Either way, once that is done you can just copy the contents of the “” directory (whatever it is now called :wink: ) back into the “new” directory.



Well, I really did upgraded WP just really recently, and it also puzzles why the /old folder was actually the one I had 2 years back - which meant somehow my backup got stuck in time.

Following your instructions, I tried to restore the DB, and its options puzzles me. “Restore which backup?” and the actions restoring.

Hokay, so which should I choose?


Jst pick one that is dated before that “upgrade” that broke your site … preferably the latest one (prior to the upgrade), so that as much as possible of your content will be intact. :wink:

You may want to try to to an “export” of you data from the “old” blog as it sits now as a “hedge” against you database restore being somehow not what you expect (given the confusion with your version numbers).

You should be able to do that export from the blog’s admin section fro WordPress.



Exactly! I’m as confused as you are. I do upgrade WP as and when I log into DH (probably around twice a year). Do themes play a part on how it turned out wonky? I was using the Kiwi and then Unsleepable theme, which is kinda different.

The only updates I do to the db is when I it tells me to, after I’m done with the upgrade.

Would all these actually affect my log in as well?


The themes should not have affected it, but I don’t know that you can say authoritatively that it could not have - I mean a theme should not modify the database, but I suppose it could do so with PHP code. I would classify something that did that as a “rogue” or theme :wink:

Well, they shouldn’t … but there have been some reports of difficulty as a result of recent version adding a salt to the MD5 hash of the password. Usually the fix is to clear your cache, delete any WordPress cookies, close your browser, and try to log on again (sessions).

You could always try going into your database directly with PHPMyAdmin and resetting your password (make sure to account for the MD5 hash) - that process is detailed on the WordPress Codex/forums.



Hmm, It has since gone back to somewhat normal, meaning the themes were the 2 year-old ones but contents are current, but that just makes me really apprehensive about upgrading again.

Now the most fantastic problem, my entire photo gallery album is kaput. So it’s either I keep my entries or my pics…


Yeah … I really prefer to upgrade manually with WordPress! The content is the important thing … you can always update your theme(s) individually with a minimum of effort. :wink:

I’m wondering how the two could be related? What directory was your gallery installed in, and what is it’s url?



It was in, and now there’s a fatal error. Think it could be because Photogallery was a child in the parent directory too.

I tried copying the contents into the working folder, but doesn’t seem to work.

Weirdly enough, since you mentioned it earlier, my PG last updated was stated as in 2006 as well! Which is so not true cos I upgraded it in Jan as well!

And when I followed the process of upgrading…I got obviously SQL errors, and my backup ( just turns out funny.


Yeah, when I browse to your photgallery now, I see the “upgrader” screen asking me to upgrade.

I think at this point I would just assume that something went horribly wrong with the “one-click” process, and I’d revert my gallery the same way you did WordPress.

For me, the one-click upgrader has always worked flawlessly, but I still don’t like to “trust” it, because I don’t really know exactly what it does, and I can “selectively” upgrade stuff myself easily easily enough. :wink:

Fortunately, the “old” directories are still there to “unbork stuff” - and there are usually useful “snapshot” directories also. Good luck with it, and let us know how it sorts out, ok?



This was the error I got

in modules/core/classes/GalleryStorage/GalleryStorageExtras.class at line 961 (gallerycoreapi::error)
in modules/core/classes/GalleryStorage.class at line 493 (gallerystorageextras::execute)
in modules/core/ at line 1426 (mysqlstorage::execute)
in modules/core/ at line 433 (coremoduleextras::upgrade)
in modules/core/classes/GalleryModule.class at line 160 (coremodule::upgrade)
in upgrade/steps/UpgradeCoreModuleStep.class at line 85 (coremodule::installorupgrade)
in upgrade/index.php at line 185 (upgradecoremodulestep::processrequest)

Wowzer…at this point, I’m really regretting about not being a geek. Wait, would that mean my entire album of photos are gone!!!


I don’t know the code of Gallery well enough to know for sure what that indicates, though I suspect it has to do with differences between the old and new code (from the borked update).

Well, I know what it “means”, but not how it got that way or the best way to hack it back into shape. Maybe the gallery forums could shed some light on it.

Did you try just putting everything back the way it was (using the DB restore and the “old” (or .snapshots) directories)?



Okay, this episode has left me shaken. Any idea how do I prevent this from happening again? I’ve checked blog and it still states it hasn’t been upgraded since 2006, but one-click says its already v2.3.3!

Edit: And, the backend has also reverted back to ancient (ie v.2.0 times!)


I can certainly understand that; I’d be “shaken” too! I have no idea how to “prevent this from happening again”. I have no idea how it happened in the first place, so any suggestions on how to prevent it would be just uninformed guessing.

It seems to me that, somehow, your site(s) have gotten “out of synce” with the one-click installer - which has never happened to me before and I don’t know how it might have occurred.

At this point, I’d suggest putting everything in front of support, and seeing if they can make any sense of it.

That’s even stranger … it’s definitely time for a support ticket, and I’d love to learn what they say might be causing this.



Tell me about it…I’m too afraid to see what I could encounter with whenever I type my blog’s URL.

Have already sent them a support ticket when I posted here last night concurrently…no reply from them yet though