Blocking FTP to public


#1

Right now, it is possible to go to http://www.daemondeveloper.com/images and see my images for my site. How can I block this page from the public and instead give a 404 Page not found error or something?

I think you normally edit the .htaccess file right?

But how do you do this from the cPanel?

Thanks


#2

Adding

Options All -Indexes

To your .htaccess should take care of your issue.

You can probably do that from the webftp option on the manage domains page in the panel.


#3

Ok thanks, I will give it a try

EDIT: I don’t see the .htaccess file…is it hidden? or do I need to create one?

EDIT NEW: I just created a new one and it worked. Thanks


#4

I had to create a sub-domain and user so I could test out webftp, I have ftp disallowed and random password strings on existing users.

Interestingly, I can’t figure out how to display hidden files on dreamhosts webftp. I was able to upload a file named .htaccess but it doesn’t show in the directory listing. The more of the story, is don’t depend on dreamhosts webftp… use a real client (such as filezilla or winscp) or a firefox addin such as fireftp.

Best practice anyway is to disable ftp and use SFTP.