Bitrix setup wizard says ".htaccess processing is off"


#1

hello,

i’m new here, i use “trial 2 weeks period” of DH and try install CMS Bitrix (www.bitrix.com) but Bitrix Wizard says me “.htaccess processing is off”. Bitrix support say that i should uncomment “AllowOverride All” in httpd.conf. How i can solve this problem, what do you can recommend me?

Thank you!


#2

Not to ask a stupid question but did you uncomment what it said? You will need to open httpd.conf in your text editor (notepad if you have nothing else) and do what the instruction says. Usually commenting will be a # (which makes whatever software ignore that particular line) so remove the one in front of AllowOveride All and save the file and upload it to your website.


#3

It is clear BUT do I have permission to edit httpd.conf of Apache? I think I have access by FTP to directory with my web site files only, isn’t it?


#4

You’ll have to forgive me. I try not to make posts when I’m half asleep. I doubt DH’s configurations are what’s wrong since my htaccess files are all working fine and doing what they are supposed to do.

As bitrix seems to be a paid application and I’m not willing to sign up for their demo version it will take me a bit to acquire my own copy for testing purposes. I’ll get back to you and tell you if I was successful installing it or not and what problems (if any) I encountered.


#5

The problem is actual only for the case “UTF-8” option checked during installation.

Installation consists of some steps:

  1. download bitrixsetup.php to web site directory
  2. run it
  3. choose “english”
  4. choose “Corporate portal”
  5. choose “UTF-8” (!)

#6

Hmm I was only able to find version 6 and I think their latest version is up to 9 so I don’t know how helpful that would be. Try contacting support to see if there is some issue with the handling of .htaccess files on your domain. If that isn’t the problem though I wouldn’t know what to tell you since I can’t try installing a more current version.


#7

You can try install my copy of Bitrix here:
http://www.orangecode.dreamhosters.com/index.php

  1. Click “Далее” (“Next”)
  2. click checkbox (egreement)
  3. unchoose first checkbox and click second checkbox (UTF-8)
  4. ckick Next
  5. you will see RED color string “… .htaccess”, it meens that “.htaccess processing is OFF”

#8

Even if some of the stuff was marked in red the process should still go forward, just some functionality would be lost (as far as what the wizard was saying). Go back and uncheck utf-8 encoding and then it will let you proceed with your database information and such.


#9

It is clear BUT I want use UTF-8 exectly :slight_smile: It is very important for me!


#10

To enable UTF-8 options you do need to have .htaccess processing set to ON.
There are some special options for mbstring that need to be processed in .htaccess file.
These options will be created during installation:
#php_value mbstring.func_overload 2
#php_value mbstring.internal_encoding UTF-8

Note that you need to uncomment these lines (remove the # sign).
You can find more information in this issue here:

Do not hesitate to contact Bitrix’s Helpdesk.


#11

Dear vdv,

the main problem is I chose plan “Web hosting” (= “Virtual hosting”) -> I don’t not have permission to edit PHP.INI -> I can not uncomment string “AllOverride All” -> status of “.htaccess permission” is “OFF” -> uncommenting of “php_value mbstring.func_overload 2” and “php_value mbstring.internal_encoding UTF-8” HAVE NOT power :frowning:

Note that there is no issue with UTF-8 using on virtual hosting in case of CMS Joomla 1.5…


#12

php_value doesn’t do anything on DreamHost (unless you’re specifically using mod_php on a DreamHost VPS). See the instructions at http://wiki.dreamhost.com/PHP.ini for details on how to set those two mbstring options.


#13

If you do not have possibility to use .htaccess files all your changes will not take effect.
You can try to ask administrator to perform such changes for you.

And as far as I see these settings (php_value) won’t be used on this hosting.
So you should better check how to set this options on your tariff plan.
(php.ini or so)

You can also use “bitrix server test” script to see if your system meets Bitrix products requirements or not.
Ask Bitrix’s Helpdesk for more assistance with script and some extra checks.

Also write to DH administrator with direct question about mbstring options.

hth