Big files and FTP (Cyberduck FTP)


#1

Hi,

Im on Mac using Cyberduck ftp client and im trying to upload a 185mb mp3 file to Pierce server. When the upload reaches 120m aprox at the usual speed of 30-40kb/sec (i dont know if this is the normal upload speed) the speed starts do decrease and the upload time starts to increase until i loose my patience.

I need a fast answer because im curator of a podcast and the audience is downloading an incomplete file.

Thanks!


#2

Switch to SFTP. Make sure your User in the panel is set for SFTP access as well. SFTP is a more robust protocol than FTP.

-Scott


#3

Probably more important than the transfer size is the time taken. Several FTP servers have strict command-channel timeouts and have bugs ignoring data-channel traffic. That-is: They haven’t seen any commands from the client within their timeout period and drop the connection regardless of a file-transfer in-progress. (PureFTPd is one such server)

Possible workarounds:

  • Use SCP (Must be enabled for user): “% scp LOCAL_FILE USERNAME@SERVER:PATH”
  • See if you can configure your FTP client to send NOP/keepalive commands while data transfer is in progress (This works for some servers)
  • Use WebDAV (DreamHost’s WebDAV implementation kind of boxes you in on security grounds though)
  • Use a different FTP client that does a keepalive/NOP during transfer that the server can accept (Yeah, that’s a bit vague).
  • Increase your upstream bandwidth.


Computer scientist