Backups User, SFTP, Filezilla, timestamps


#1

Context:

  1. Backups User
  2. Latest Filezilla Client on Windows
  3. SFTP Connection
  4. Key (passwordless) authentication

Problem:
Raw directory listings returned to FileZilla are not consistent depending on age of the modified date timestamp. I am trying to essentially invoke an alias of the ‘ls’ command so that when Filezilla uses it to retrieve the directory listing, the timestamps returned are consistent in format and complete. The alias I would like to have in effect is:
alias ls='ls -al --time-style=full-iso’
or
alias ls=‘ls -al --time-style=long-iso’

I have tried to invoke the alias by putting the above in ~/.bashrc, ~/.bash_profile, and ~/.ssh/rc without success.

Any ideas?

Jay from Toronto


#2

Is it a daylight savings time problem? until windows 7 microsoft really didn’t deal with the conversion correctly.


#3

It is not related to Windows, time zones, nor daylight savings. It is the raw timestamp data returned by the Dreamhost server that I am trying to alter to be consistent and complete.


#4

The file listings returned by FTP are not affected by your shell settings. I believe they’re generated internally by our FTP server software (ProFTPd), so there’s probably no easy way to adjust them; if you need exact timestamp information, I’d recommend using SFTP instead of FTP.


#5

I think you can override them from the ‘Interface->Date/time format’ page of FileZilla using format strings - http://wiki.filezilla-project.org/Date_and_Time_formatting

EDIT: Just noticed you said ‘raw’, so this might not be good enough.


#6

I AM using SFTP. See original post.


#7

The timestamps transferred by SFTP are raw time values (not formatted). Any formatting that’s happening is being performed by your client, so check your Filezilla settings to see if there’s any way to get what you want there.