Backups user rsync, ssh, and passwordless logon


#1

I’m trying to setup a script using cygwin to synchronize a directory with my backups. I got past the issue of protocol=29, and I can get the script to run okay, but I get prompted for my password. I tried using an ssh key with ssh-keygen, but after some back and forth with dreamhost support, I finally get this message:

“Unfortunately, it looks you were told some incorrect information. We don’t offer backup accounts ssh access, so trying to rsync to a backup account via ssh won’t work.”

Okay, so no ssh keys for rsync backups. When I try the --password-file switch, I get the error “The --password-file option may only be used when accessing an rsync daemon”. I’m not sure what this means; I can log on okay when I’m prompted to enter my password, so I assume that I’m connecting to an rsync daemon at some point.

I’ve tried the --password-file switch with and without --protocol=29.

So how can I get nightly backups going on cygwin without having to have someone around to enter a password?


#2

Looking at the man page a little more, I see that in order to tell rsync that you’re connecting to an rsync daemon, you prefix the host with ‘rsync://’ . I used that, but I got the error ‘connection refused’.