Backup with DH backup user, DeltaCopy's rsync shell


#1

I am trying to use DeltaCopy (http://www.aboutmyip.com/AboutMyXApp/DeltaCopy.jsp) to sync data directly from a Windows XP (Home) machine to my DH backup account, but my inexperience with a Linux environment is hampering my ability to troubleshoot. I am in round 4 of an email exchange with DH support, but I still can’t get DeltaCopy to log in to the backup account (after triple-checking my username password, using cut-and-paste into FTP software, and logging in successfully). I’d REALLY welcome anyone’s helps, especially if you’ve gotten rsync working with your backup user and most especially if you’re able to get DeltaCopy working.

Here’s the error:


Executing: rsync.exe -v -rlt -z --delete “/cygdrive/C/test.txt” "b######@backup.dreamhost.com::testdir/test.txt"
rsync: failed to connect to backup.dreamhost.com: Connection refused (111)

rsync error: error in socket IO (code 10) at /home/lapo/packaging/tmp/rsync-2.6.6/clientserver.c(98)

Error in socket I/O
Profile ‘Daily’ executed in 7125 milliseconds. One or more errors were encountered.


As you can see, it looks like the login isn’t working. If you were me, what would the trouble-shooting tree look like? Maybe I should reinstall deltacopy in case the installation is corrupted?

Oh, one other thing: Does the “b######@backup.dreamhost.com::testdir/test.txt” bit look right? I see two colons there (inserted, I presume, by deltacopy since I didn’t put them in), and I’m not sure if I should have a value other than ‘testdir’ in deltacopy’s “Virtual Directory” field. That directory does exist in the root of my DH backup account.


#2

For starters, log in to a shell account on your web server here and try the same command. For testing, change your destination to ~/test.txt, and make sure that file exists in your home directory on your web server.

Looking at your command, I don’t think plain ol’ rsync will work. It needs a flag of -e ssh before the --delete flag. Hopefully you can configure DeltaCopy to use SSH (SFTP) for the sync.

-Scott


#3

Ok, I was the one who first commented on the DeltaCopy thing on the other thread…

So, first off, choose “Connect via SSH” in the options. You’ll get a connection, but it’ll probably just hang. This is because SSH is asking if you want to accept the fingerprint.

I had more success just running rsync using cmd.exe and pasting in the “Display run command”. I got a connection, and was able to choose to accept the fingerprint and enter your password, and it worked fine after that.

DeltaCopy seems to have an issue with authentication. Even entering the password it doesn’t seem to want to enter it when rsync asks. An alternative might be to save the key so it automatically logs in. See: http://www.aboutmyip.com/AboutMyXApp/DisplayFAQ.do?fid=1

I haven’t gone thru the steps of saving the key yet, I’m just using the command line manually at the moment. If you do get it to work by saving the key, let me know!

Cameron


#4

Thanks, Scott and Cameron! I got it working. I created a Wiki article (http://wiki.dreamhost.com/DeltaCopy) summarizing the steps to take, but here’s my log in case its helpful. You are more than welcome to make changes to the Wiki article.

I changed destination from “/testdir/test.txt” to “~/testdir/test.txt”, added the -e parameter, turned on ssh, and ran it again. After 15-25 seconds, my virus protection software and my firewall both popped up with warnings about rsync. While I was whitelisting it, rsync failed, but at least it got further:


Executing: rsync.exe -v -rlt -z --delete -e “/cygdrive/C/test.txt” "b######@backup.dreamhost.com:~/testdir/test.txt"
rsync: Failed to exec /cygdrive/C/test.txt: No such file or directory (2)

rsync error: error in IPC code (code 14) at /home/lapo/packaging/tmp/rsync-2.6.6/pipe.c(83)

rsync: connection unexpectedly closed (0 bytes received so far) [receiver]

rsync error: error in rsync protocol data stream (code 12) at /home/lapo/packaging/tmp/rsync-2.6.6/io.c(434)

Error in rsync protocol data stream
Profile ‘Daily’ executed in 39625 milliseconds. One or more errors were encountered.


Then, per
http://discussion.dreamhost.com/showthreaded.pl?Cat=0&Board=forum_troubleshooting&Number=112822, I ran rsync from the Windows command line:


Start > Run > cmd.exe

C:>cd \Program Files\Synametrics Technologies\DeltaCopy

C:\Program Files\Synametrics Technologies\DeltaCopy>rsync.exe -v -rlt -z -e ssh --delete “/cygdrive/C:/test.txt” "b######@backup.dreamhost.com:~/testdir/test.txt"
The authenticity of host ‘backup.dreamhost.com (205.196.216.115)’ can’t be established.
RSA key fingerprint is [hash]
Are you sure you want to continue connecting (yes/no)? y
Please type ‘yes’ or ‘no’: yes
Warning: Permanently added ‘backup.dreamhost.com,205.196.216.115’ (RSA) to the list of known hosts.
b######@backup.dreamhost.com’s password:
building file list … rsync: link_stat “/cygdrive/C:/test.txt” failed: No such file or directory (2)
done

sent 25 bytes received 20 bytes 1.48 bytes/sec
total size is 0 speedup is 0.00
rsync error: some files could not be transferred (code 23) at /home/lapo/packaging/tmp/rsync-2.6.6/main.c(791)


I followed the instructions at (http://www.aboutmyip.com/AboutMyXApp/FAQList.do?cid=1), “Can I use SSH with DeltaCopy?” to download and install cygwin. The ‘ssh-keygen’ command failed the first time I ran it, and the DeltaCopy FAQ isn’t terribly clear about which SSH module is needed, but installing these four got it to work:

  • autossh
  • libssh2
  • libssh2-devel
  • libssh2_1

Any thoughts on which of these are need and which aren’t? Feel free to cull down the list in the wiki.

The FAQ instructs you to place the key in /cygdrive/c/Program\ Files/Synametrics\ Technologies/DeltaCopy/sshkey. I found that /cygdrive/c/Program Files/Synametrics Technologies/DeltaCopy/sshkey works; apparently, cygwin adds forward-slashes (escape characters?) before spaces, so that /cygdrive/c/Program\ Files/Synametrics\ Technologies/DeltaCopy/sshkey actually becomes /cygdrive/c/Program\ Files/Synametrics\ Technologies/DeltaCopy/sshkey. I’ve notified the webmaster and omitted the extra slashes in the wiki article.

I had to copy cygwin1.dll from C:\cygwin\bin to the C:\Program Files\Synametrics Technologies\DeltaCopy\ directory.

DelataCopy still hung. I had to run rsync from the command line, and verify backup.dreamhost.com the first time:


C:\Program Files\Synametrics Technologies\DeltaCopy>rsync.exe -v -rlt -z --delete -e “ssh -l b###### -i sshkey” “/cygdrive/C/test.txt” "b######@backup.dreamhost.com:~/testdir/test.txt"
The authenticity of host ‘backup.dreamhost.com (205.196.216.115)’ can’t be established.
RSA key fingerprint is [hash].
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added ‘backup.dreamhost.com,205.196.216.115’ (RSA) to the list of known hosts.
building file list … done
test.txt

sent 108 bytes received 42 bytes 14.29 bytes/sec
total size is 19 speedup is 0.13


After that, it ran fine in DeltaCopy:


Executing: rsync.exe -v -rlt -z --delete -e “ssh -l b287184 -i sshkey” “/cygdrive/C/test.txt” "b######@backup.dreamhost.com:~/testdir/test.txt"
building file list …
done

sent 47 bytes received 20 bytes 14.89 bytes/sec

total size is 19 speedup is 0.28

Profile ‘Daily’ executed in 4843 milliseconds. It ran successfully.



#5

Thanks, Scott, I got it working. See http://discussion.dreamhost.com/showflat.pl?Cat=0&Board=forum_troubleshooting&Number=112802


#6

Thanks, Cameron, I got it working. See http://discussion.dreamhost.com/showflat.pl?Cat=0&Board=forum_troubleshooting&Number=112802