Awstats: permission denied

apps

#1

I have followed the instructions for installing awstats, but when I try to verify that the installation worked correctly by opening the awstats.asuh.com.html file, it gives me the following error:

sh: line 1: /home/asuh/awstats/awstats.pl: Permission denied

I am not sure why this has occured but would like to know if anyone can suggestion a solution. I need my awstats!!


#2

Just to follow up on my problem, I hadn’t yet run the cronjob which was the next step. Even after running it, I still got that same error. So, to fix it, I ended up running the perl line command again and that seemed to fix it.

Now if only i could only figure out how to stop these hourly e-mails and have the update button appear on the awstats page. Oh, and actually getting it to update would be nice.


#3

edit the config file (in the awstats cgi-bin directory) and look for a setting re “update from browser” - it’s easy to find.

Hope that helps.

Cheers.

Want to save? Use promo code sweetdream25 and save $25 instantly. This chart lists the plans.


#4

Yes, I already did that. I should have specified that in the last post. In fact, there are two things that have to be changed in the config file for the update to actually show up. I have changed both, but neither have enabled this button to show up.

I’m also still having trouble with awstats to automatically update. I have to go into shell prompt and run the perl command everytime to see the changes on the pages.