Awstats on wordpress

apps

#1

I’m having trouble getting awstats to work correctly on two of my sites where wordpress is installed in the root directory. On two other sites where wordpress is installed in a subdirectory (ie, example.com/blog) awstats works perfectly.

Anyone have a clue on this?

Thanks


#2

This worked for me:

http://wiki.dreamhost.com/Making_stats_accessible_with_htaccess

-Scott


#3

Thanks for the response, but I had already tried that.

I actually did find out what was wrong, just in case anyone else has this problem.

There were a couple of typo’s in the configuration file. It was just a coincidence that both sites were wordpress blogs in the root directory. In one, I had an additional double quotation mark in one line that was messing everything up, in the second, I found that I had edited the log file format in the example, which was commented, leaving the default one. Stupid I know.

The way I figured out the second problem was by running the awstats.pl file from the command line. That tool reports errors pretty well.

Get $50 off new registration. Just us promo code 50DOFFLGH460 in the checkout box.