Awstats not updating



I got awstats installed but i can’t seem to get it to update

I followed this guide

When doing the cron part i enter what it says changing the appropriate parts, so it now looks like

[quote]perl /home/carebearcez/awstats/tools/
-update -awstatsprog=/home/carebearcez/awstats/cgi-bin/

its set to update hourly but it doesn’t


you will need to provide the path to perl at least. try with /usr/local/bin/perl

So the final one should be something like

0 3 * * * /usr/local/bin/perl /home/carebearcez/awstats/tools/ -update -awstatsprog=/home/carebearcez/awstats/cgi-bin/
-dir=/home/carebearcez/ >/dev/null 2>&1

$50 off and 3 free domains with code: [color=#CC0000]DH3[/color] Sign Up NOW or More Codes Here


That’s not the cron part–that’s the part to make sure it’s working. Read further down the page for the cron section.

Also, if you’re copying & pasting the code like that, you’ll have a line break problem. Note the warning down by the cron section:

So, be sure it gets entered on one line when you set it up.

:stuck_out_tongue: Maximum savings promo code: MaxSavingsAtDH


I’m getting confused at the end of the guide. At the beginning it says to move the files out of the cgi-bin directory into the awstats directory.

The further down under configuration
it says to go to the directory and copy/edit files, which no longer exist.

At the begining it tells you to place the awstasts folder in /home/yourusername/ but at the end the urls have have it in

which doesn’t make sense since thats not where the awstats folder was placed


That is to set up AWStats for multiple domains. Let’s if you have more than one domains hosted with the same user.

If you have only one domain, you should stop at

$50 off and 3 free domains with code: [color=#CC0000]DH3[/color] Sign Up NOW or More Codes Here


i have it set up on 1, but plan on settings it up for 2 more when i get the first one working.

Currently its being used on but it will be being used on and


Even then, the logs are separate. I run awstats in the /stats directory of each domain I monitor, each with their own configuration and cronjob. I also run each domain under a different user, but regardless, I like to keep all my activities separate.



i decided to put awstats into each directory and followed this since it was easier

seems to be working now