Awstats & geoip

apps

#1

just a quick post to let anyone out there knom how to enable the showing of a country’s flags in your awstats reports:

in your .conf file for awstats:

uncomment and edit so it looks as follows:

LoadPlugin=“geoip GEOIP_STANDARD /usr/local/share/GeoIP/GeoIP.dat”

or for the free type:

uncomment:

LoadPlugin=“geoipfree”

thats it, now it will only calculate these for your current maybe months stats, so i had to reset my stats (by deleting contents of awstats/data folder) to get rid of old unresolved IP hits.


#2

I tried to enable both plugins and it didn’t work. Do I need to delete the contents of the data folder? Deleting this will delete all the reports only and they will be recreated, right?

My stats aren’t being updated (even if set to be updated by the browser) so I think that I need to delete the data and start from scratch. I asked the support for an answer but… it was useless as always.

Will it matter if I am using JAWStats too?


#3

I deleted these files, enabled the free plugin and now my stats are all messed up, but at least now I can see the countries…

First, it’s just showing up the stats from Sept. 21 ahead. I had to almost reinstall awstats so it could work, it was showing stats of random days. After I fixed it (tried to recover several logs but none could be read), I’ve lost 2 weeks of stats (the site started Sept, 7th.). All this in JAWStats, not in AWStats, which is even worse.

If I run the stats through the AWStats report page, there isn’t an update button neither the stats seem to be updated at all - they stopped at Sept. 13th according to the page. I was suggested to run the awstats.pl (not by DH’s suppport, which isn’t helping me at all) manually from the command line forcing an update, but… it failed. It was killed, message said I was using too many processes (how so?). It even killed some instance of pico I tried to use afterwards.

The update from the JAWStats doesn’t seem to be working either, although it is at least updating once a day or something. I will now try a cron from the command line and see if it works.

I’m afraid that it has messed up all the logs. I don’t want to reinstall AWStats from scratch but I think this will be the option. I hope that I can fix that before October…

WTF, DH?