AWStats and empty stats

apps

#1

I spent a bit of time recently setting up awstats, and everything seems to be working fine except that my stats all show zero (and I’ve tried this on a couple domains now). I haven’t been getting any error messages and I’ve doublechecked all the settings in the conf file.
I checked the AWstats FAQ and found this:
http://awstats.sourceforge.net/docs/awstats_faq.html#EMPTY_STATS
but it hasn’t been much use as I’m sure the Log Format is correct (I used the wiki awstats installation guide), and it’s looking at the current year/month.
Does anyone have any ideas?


#2

I also has problem with Awstats and din’t want to start new topic so I will ask for help here :wink:

I tried install awstat just as it wrote in wiki step by step but when I came to checking file awstats.just-whitney.com.html I got such error and I am not sure what is wrong

Error: SiteDomain parameter not defined in your config/domain file. You must edit it for using this version of AWStats.

Setup (’/home/xxxxxx/awstats/cgi-bin/awstats.just-xxxxxx.com.conf’ file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in ‘docs’ directory).

Did I set wrong attribiutes? I was instaling awstats just like is wrote here http://wiki.dreamhost.com/index.php/AWStats_Installation


#3

I actually got mine working. I’d simply left off the first forward slash in the Logfile line in my conf file.

Lily what does your SiteDomain line currently read? It should be SiteDomain=“yourdomainname.com


#4

Len I had something like this is sitedomain line

SiteDomain=“just-whitney.com


#5

It finally works :slight_smile: I installed awstats once again and now it is fine.

But I had another problem :frowning: I can’t set up crontab. I read everything and wiki but still don’t get it. Can anyone write me step by step what to do? Have I create some file? and where should I put it?

Please hel me :frowning: I wish awstats was in dreamhostpanel, my previous host had c-panel so didn’t have to install awstats.


#6

Hello People.

I can’t get AWStats working.

I’ve proved everything! First i thought it was the log format, but i donwload my access.log to my local PC (where i have a running AWStat installation working OK) and it parsed correctly.

I don’t know what else i can do. I did what the Dreamhost wiki said to:

http://wiki.dreamhost.com/index.php/AWStats_Installation

But still doesn’t work.

How did you do it? Did you installed with apt-get?

Thanks!