Avada Theme (Themeforest) demo installs failing on DreamPress

wordpress

#1

I’m looking for a little insight with some troubleshooting.

I’m using the Avada theme (by Envato/Themeforest) on the DreamPress managed hosting. In attempting to load their demo files, I’ve run into problems. While it reports that the system settings are fine, it crashes with an undefined error.

Here is the addition I made to the wpconfig.php file to ensure memory allocation is in line:

[php]define( ‘WP_MEMORY_LIMIT’, ‘256M’ );[/php]

Here is what I placed into the phprc file I created to satisfy the php.ini requirements:

memory_limit = 256M upload_max_filesize = 64M post_max_size = 64M max_execution_time = 500 max_input_time = 500 max_input_vars = 3000

Even though it’s own system checks acknowledges that these values are all in order, it continues to crash.

The theme creator offers two other workarounds. One is to install the “All-in-One WP Migration” plugin that brings in their complete archive. That too simply hangs after a time.

The third option they give is to use the WordPress admin dashboard Tools -> Import -> WordPress option to bring in their XML file. It uploads fine. I then set the import author to my admin account, check the box requesting that it Import Attachments, and hit the submit button. It seems to work away in the background for about 2 minutes, and then it fails, leading to the following error in the browser:

Error 503 Service Unavailable Service Unavailable Guru Meditation: XID: 907911940 Varnish cache server

Is DreamPress’ varnish mucking something up in the import, or …?

After spending the entire day troubleshooting and reading everything I can get my hands on, both in the theme creator’s documentation, and in DreamHost’s wiki support, I’m at a dead end.

Has anyone else been able to successfully install any of the Avada demo files on DreamPress? Alternatively, can anyone see something in what I’ve shared above that suggests I’m missing something obvious, or going about it the wrong way?

Much gratitude for any light folks may be able to shine on this to get me sorted out again. I’m pretty comfortable with both WordPress and the DreamPress managed hosting, but this one’s got me stumped.

Gratefully,
Sue.


#2

How big are their demo files? It sounds like you’re running into PHP timeouts more than anything else, but if the file is very large, it could be overrunning the cache’s memory buffer :confused:


#3

Thanks a bunch for the suggestion. The demos are fairly large. The timeout was what I had been wondering about myself. I was able to locate the server error logs to finally identify exactly what it was throwing.

When trying to install any of the demos I get the following error in the server logs:

When using an alternate method, installing the demo from a .wpress backup file, the import happens correctly, but then stalls out once the installation starts, and does so almost immediately, generating the exact same error as above.

I’m not knowledgeable enough to understand what this error means, but should likely be running it by the theme creator now that I know what error it’s throwing.

Does this look like a general WordPress error, or something to do with the theme itself?

Thanks again, very much!
Sue.


#4

I also have the same problem attempting to install one of the Avada demo themes. It comes up with an error advising me to check Avada’s System Status tab to make sure there are no warnings regarding server and WordPress configuration settings.

I’ve edited the wp-config.php and phprc files accordingly so that the Avada System Status tab shows that everything should work fine. I’ve then run the WordPress Reset plugin (when the demo install failed, it recommended to run this before attempting to install the plugin again), yet when attempting to install any demo theme I continue to have the same problem.

Surely there are other people using DreamHost and one of the Avada demo themes. Did anyone else have any problems setting this up?

Regards,
Andrew


#5

We just bought the Avada theme. Before I change the memory settings, I’m wondering if anyone has had success installing the demos?


#6

I am having the exact same issue as the initial poster, been through pretty much the exact same steps too!

Purchased Avada on 04/10/15. I have had both Avada and DreamHost support involved and still having the same issues…

Did anyone else have any success in getting this to work?


#7

My issue was a bit different to OP but I discovered that despite the errors coming up, the theme still worked properly. DreamHost support was not able to resolve the errors and blamed the theme. To rule out issues with the theme, I repeated the exact same steps with another shared hosting provider (Site5) and did not run into any errors or problems.


#8

It’s a memory issue. We limit the memory you can use for any one PHP process (for sanity). The import Aveda uses tends to go over that because of everything it has to do to import the demo data.

You can try increasing your PHP memory via your phprc file, but the demo files are … well. Large. Most people having the issue are on the smaller, shared, servers, so yes, this will be an issue.


#9

Is there a solution for this problem now?


#10

I guess silence means yes. It is a shame there was no progress in three years.