Aspell and text::aspell

apps

#1

ok, maybe somebody will answer this question for me. :slight_smile:

I’m trying to install aspell and after that the Text::Aspell module.
I know aspell is allready insatlled on my server, but the version is not new enough to work with text::aspell.

I downloaded the tar file and unpacked it via telnet. I then typed
"./configre && make"
that returend a bunch of text, ending with “make: warning: Clock skew detected. Your build may be incomplete.” (a google search informed me this was nothing to worry about)

so I typed in
"make install"

and that returned this:
“Making install in .
make[1]: Entering directory /home/.unbelievable/harts/aspell-0.60.3' make[2]: Entering directory/home/.unbelievable/harts/aspell-0.60.3’
test -z “/usr/local/lib” || mkdir -p – “/usr/local/lib”
/bin/sh ./libtool --mode=install /usr/bin/install -c ‘libaspell.la’ ‘/usr/local/lib/libaspell.la’
/usr/bin/install -c .libs/libaspell.so.15.1.3 /usr/local/lib/libaspell.so.15.1.3
/usr/bin/install: cannot create regular file /usr/local/lib/libaspell.so.15.1.3': Permission denied /bin/sh ./libtool --mode=install /usr/bin/install -c 'libpspell.la' '/usr/local/lib/libpspell.la' libtool: install: warning: relinkinglibpspell.la
(cd /home/harts/aspell-0.60.3; /bin/sh ./libtool --tag=CXX --mode=relink g++ -g -O2 -fno-exceptions -o libpspell.la -rpath /usr/local/lib -version-info 16:3:1 -no-undefined lib/dummy.lo libaspell.la -ldl -ldl )
mv: cannot stat libpspell.so.15.1.3': No such file or directory libtool: install: error: relinklibpspell.la’ with the above command before installing it
make[2]: *** [install-libLTLIBRARIES] Error 1
make[2]: Leaving directory /home/.unbelievable/harts/aspell-0.60.3' make[1]: *** [install-am] Error 2 make[1]: Leaving directory/home/.unbelievable/harts/aspell-0.60.3’
make: *** [install-recursive] Error 1”

It seems that it’s trying to make changes to files in /usr/local/ which I understandable don’t have access to. What can I do so I can install this? thanks for ANY replies (as my questions don’t normally find answers).

-Matttail


#2

I’m a little slow to this question, but you probably have to pass an option to configure to tell it to use your home directory instead of the default installation location. It’s probably something like this:

./configure --prefix=/home/myuser

  • Dallas
  • DreamHost Head Honcho/Founder