Are these Perl Modules installed?

software development

#1

Hi there,

I am trying to install a script that requires:

DBI
DBD: MySQL

It also says that MIME:Tools is optional.

Could someone either let me know if these are installed or point me to the right person to ask? I would really appreciate it!

Thanks!

Jen


#2

I’m pretty sure that the required ones are pretty standard. Have you checked:
https://kbase.newdream.net/index.cgi?area=996
This isn’t always pefectly up-to-date, but it has most of the common ones listed.

Looks like MIME:Tools is installed as well.


#3

I am using DBI and DBD::mysql myself, I even wrote my own scripts using them. You just have to make sure you’re connecting through the MySQL hostname instead of ‘localhost’.

I have not used MIME::Tools myself, but the Knowledge Base has it listed as being installed.