Apple's Compressor FTP Settings


#1

I’m attempting to upload videos using Apple’s Compresser app thru our FTP connection. But when I attempt the most logical route it always fails.

That route is:
ftp://username:password@otwcmediasalesproduction.com

I’ve tried all kinds of combination “file paths” and every single one fails to connect.

I’ve found only one way to connect and don’t like it:
ftp://username:password@69.163.185.106

This drops the video right on the very top most layer of the server instead of inside the otwcmediasalesproduction folder. If I attempt to add a file path like “/videos”. It fails. Even tried “/otwcmediasalesproduction” as a file path.

WHAT THE HECK IS GOING ON?
Someone help me stop running into this wall please.


#2

FTP by default drops you into your home directory. You have to issue an FTP command to ‘cd’ into another directory. Another option would be Directory Mapping, so you FTP to a different user where your site uses that user’s home directory for your /videos web directory.
http://wiki.dreamhost.com/KB_/Account_Control_Panel/Domains::_Remap_Sub-Dir


#3

If I interpret you correctly you’re saying I should use something like [color=#000080]ftp://username:password@69.163.185.106/videos or
ftp://username:password@69.163.185.106/otwcmediasalesproduction.com/videos[/color]

I’ve tried both of those and failed each time.

Why wil[color=#000080]l “ftp://username:password@otwcmediasalesproduction.com” [/color]fail but the IP succeed?


#4

No, you can’t FTP to “server/directory.” That’s why you need to issue a second command to drop into that directory.

I don’t know why the IP address works, but the domain doesn’t. I can’t FTP through my work’s firewall to experiment, but maybe it’s an issue with Compressor. See if that format will make some headway from your browser. What is its failure message?