Anyone get Webmin on Ubuntu 14.04 to work?

dreamcompute

#1

I’ve been trying and failing to get Webmin to work on my Ubuntu 14.04 instance. HAs anyone here succeed or know how?

Installation appears to go smoothly, port 10000 appears to be open, but when I try to login to webmin using my dreamcompute instance ip https://instance_ip:10000 I just get “This site can’t be reached.”

Guides I followed on various instances:


#2

I hadn’t yet tried this install, but did it just now to write up a quick howto. I tried the method in the links there, but they didn’t work for me. For example the sources.list and apt-get update just kept returning:

Err http://download.webmin.com sarge Release.gpg
Unable to connect to download.webmin.com:http

I instead followed the official directions for debian on Ubuntu 14.04 available here:

http://www.webmin.com/deb.html

Steps:

  1. Open port 10000 on security group, make sure security group is in use for your instance.
  2. Login to your instance, and “sudo su -” to become root.
  3. Set a root password as webmin seens to need this for login, so run “passwd”.
  4. Install some needed dependencies:

apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions python

  1. Run this to download the package:

wget http://prdownloads.sourceforge.net/webadmin/webmin_1.791_all.deb

  1. Install it with:
    dpkg --install webmin_1.791_all.deb

  2. Go to the URL and login with username root and the password set in step 3.


#3

Have you opened port 10000 in the [iad2.dreamcompute.com/project/access_and_security/security_groups/](security groups)? Read the guide on how to do it: https://help.dreamhost.com/hc/en-us/articles/215912838


#4

Tried to follow the instructions on that page, but I’m not finding it very clear how to open port 10000. When I click “Add Rule” for my default security group, it is unclear to me which type of rule to select. Do I just do “Custom TCP Rule” with port 10000 and all the other settings with default values?
[hr]

Not sure if I opened port 10000 correctly, but steps 2-5 worked fine. Then step 6 definitely didn’t work. Here is what I got:

root@5ps:~# dpkg --install webmin_1.791_all.deb dpkg: error processing archive webmin_1.791_all.deb (--install): cannot access archive: No such file or directory Errors were encountered while processing: webmin_1.791_all.deb[/code]


#5

Create security group:

https://iad2.dreamcompute.com/project/access_and_security/security_groups/create/

call it something like ‘Webmin’. Save it.

Then hit the button “Manage rules”, add rule like the screenshot below:

that should do it.


#6

Awesome, thanks for the clarification! That was the missing step that made Webmin installation possible!

The guide at https://www.digitalocean.com/community/tutorials/how-to-install-webmin-with-ssl-on-ubuntu-14-04 worked flawlessly for me after opening 10000 in security groups.