Anyone able to install PhpGedView on Dreamhost

apps

#1

I have been trying to install PhpGedView 4.0 since beta3 (now stable version) on Dreamhost but for some reason I am unable to do so,

In IE when I try to install I get 'The page can not be displayed’ message.

In FF I get 'This page isn’t redirecting properly’ message.

I tried two different hosts no such a problem installation was successful on both hosts, any idea(s) why I can’t install PhpGedView 4.0 on Dreamhost or has anyone able to install this on Dreamhost.

Thanks

Aravot


#2

Anyone?


#3

WEll, I check out this software and it seemed intereting. My Mother in law is big into geneology and I decided to try this out to see if I could help you get it installed and see if I could provide the software for her.

It seems that the software assumes that if you’re using php4 you then must also be using mysql 3.x. So that’s the first major issue. However as long as your running php5, then it works with the mysql server.

While I was writing this post I apparently messed around with something because now I’m getting bunches of php errors when loading the editconfig.php. Also I don’t have a GEDCOM file so I can’t do much of anything wiht the software till then. Seems a downfall to me on their part not to provide a default file to work with. (have you a file I could use to check out the software?)

Let me know if you’re still having problems, perhaps I can help more.

–Matttail
art.googlies.net - personal website


#4

Dreamhost server is running PHP 4.4.2 and MySQL 5.0.18

My other host (hostpc.com) which I want to discontinue and move everything to Dreamhost, PhpGedView works perfectly since v4.0 beta 3 (recently upgraded to v4.0 stable version) is runs PHP 4.4.2 and MySQL 4.1.20

Sorry I don’t have a GEDCOM file, I have but it contain 6 generation of family info which I can’t give out, I’ll try to create a fake one and send it or you could try PhpGedView website.

I have posted my problem in their forum too if you are interested.
http://sourceforge.net/forum/forum.php?thread_id=1532121&forum_id=185166


#5

Yes, I saw your forum post at sourceforge, as well as the post you linked to. It is my guess that something about the configuration of funning php as cgi is still making it difficult to run on dreamhost.

When I went through the install I was able to get the first configuration file to load under either php4 or php5. on my php4 insatll, I selected mysql as my datbase and it wasn’t able to log in. Selecting php5 and mysql broke the software obviously. Next I tried a domian that was running php5 - this time selecting php5 and mysql allowed the configuration to go through and all seems to work.

I actually found some geneology software for my OS and have created a dummy file. Thanks though.

If you want, you can see my install at http://googlies.net/geneology

–Matttail
art.googlies.net - personal website


#6

Thanks Matttail, after couple of installation this is what I got.

Following combination works
PHP 5.1.2 and SQL 5.0.18 install OK

Following combination doesn’t Work
PHP 4.4.2 and SQL 5.0.18 doesn’t install

Hope developers fix this problem