Any DreamHost plans to install Mailman 3, in part to address DMARC problems?


#1

Hi folks,

Are there plans to install the current version of Mailman 3 so we can get more control over how to tweak list settings to work around the Yahoo/AOL DMARC problems? Mailman 2.1.18 addressed some of these issues and even that would be welcome over the current 2.1.17 - see http://wiki.list.org/DEV/DMARC

The DMARC issue came up a while back in https://discussion.dreamhost.com/thread-140790.html

Mailman 3 has been out for almost a year now, so it’s no longer new.

cheers… -Adam


#2

PLEASE!!!


#3

I’ve asked DH Support twice now to install a newer version of GNU MailMan. Sadly, upgrading the 2.5 year old version of MailMan 2.1.17 is not yet a priority. They don’t seem to understand what is wrong with 2.1.17. We need to tell them directly, in a support ticket.

Mailman 2.1.17 does not include any information of who the message was sent from WHEN the user has not properly configured their email client with a person name. Every time certain people send a list message, no one knows who it is from. It is a constant problem that DH has the ability to fix by upgrading to any newer version of MailMan.

Mailman 2.1.17 always discards the from email address, which is also a problem. Pre-DEMARC versions of MailMail did not discard the from address. I well understand the problems that the whole DEMARC thing has caused, but rather than continue to whimper & cling to victimhood, we need to bravely move forward.

Later versions of MailMan repaired these flaws.

Please DreamHost, upgrade to a later version of MailMan. This is really important to the groups that use MailMan.


#4

I tried the support ticket a year or more ago. Dreamhost’s response was rather blunt:

[quote]Unfortunately, we’re not currently upgrading the discussion list software at this time, sorry about that!

If there’s anything else we can help you with, please let us know.

Thanks!
Chalise [/quote]


#5

Just asked DreamHost yesterday:
Hello,

Thanks for contacting DreamHost support. While there will be an eventual
move to Mailman 3, I cannot say when it will be. I apologize for the
inconvenience.

Let us know if you have any further concerns,
Rob
[hr]
Wish we could convince them to do this sooner and update all the one click installers half of which are outdated


#6

[quote=“bkerensa, post:5, topic:63292”] Thanks for contacting DreamHost support. While there will be an eventual
move to Mailman 3, I cannot say when it will be. I apologize for the
inconvenience.

Let us know if you have any further concerns,
Rob[/quote]

The reply they sent me not only differs, it raises new questions:

[quote]Sorry for the delayed response

I’ve had someone look into the issue, but it seems that there hasn’t been much talk of an update. It seems that upgrades may have been blocked back in 2014, but nothing has gone on since then.

Sorry for the bad news, but maybe keep an eye on the link below to see if there’s any updates in the future.

http://www.dreamhoststatus.com/

Sorry again for the delayed response.

Thanks!
Kacy S [/quote]


#7

@smaffulli How about this?


#8

I don’t have any better answer now than what Support folks said at the time, sorry.