Anti-spammer Can't Work


#1

Dear DH gurus,

Here is my situation:

Yesterday, when I log in my wp-dashboard, I was warned “Akismet has detected a problem. A server or network problem is preventing Akismet from working correctly. Click here for more information about how to fix the problem.”

When I go to check “Click here for more information,” I read:

"
Unable to reach any Akismet servers.

A network problem or firewall is blocking all connections from your web server to Akismet.com. Akismet cannot work correctly until this is fixed. Please contact your web host or firewall administrator and give them this information about Akismet and firewalls.

Akismet server Network Status
66.135.58.61 Obstructed
72.233.69.3 Obstructed
72.233.69.2 Obstructed
66.135.58.62 Obstructed
"

When contacted DH support staff, they said they did not block any port and believed it might be the configuration problem. But

Another problem also originated yesterday is “Could not open socket” when posting comments if re-CAPTCHA is installed.

Actually, I never re-configured Akismet or re-CAPTCHA once installed, I really can’t figure out what happened.

Any guru knows how to solve my problem, kindly please offer some advice. Tons of thanks in advance!


#2

Not that it makes you feel better, but it’s working for me. Are you running the latest Akismet plugin?
Google came up with this:
http://blog.akismet.com/2009/07/13/akismet-is-up/ (over a year ago)
http://wordpress.org/support/topic/akismet-has-detected-a-problem (a better variety of suggestions)


#3

Hi, Sdayman,

Thanks for your links. Actually, before I posted my problem here, I’d already read the articles you pointed to and tried to make fixes by myself but only no prevails.

My problem came up since October 13. The version of Askimet plugin I used is the latest 2.4.0, so this shouldn’t be the issue. I also checked my php.ini file and found allow_url_fopen = On, so this is also no problem.

I went on to disable Askimet and tried to install Defensio which is an Askimet alternate as suggested in the section of Dreamhost Wiki’s fine-tuning wordpress install. After the installation, I intended to activate it but only a warning prompted indicating fsockopen() function didn’t work. As I am not tech savvy, I really don’t know what fsockopen() is and how to locate and modify its codes.

As Defensio couldn’t be activated, I deleted it and reactivated Akismet, of course, the warning “Akismet has detected a problem” again appeared. To this point, I begins suspecting the server where VPS is on might have some issues.

Making me suspect more on this was that in my WP dashboard’s Install Plugins section, the usually functioned Poplur tags suggestion is suffering this warning “An Unexpected HTTP Error occurred during the API request.” After Googling, the advised way that tweak wp-includes/class-http.php to change 'timeout’ => apply_filters( ‘http_request_timeout’, 5), to ‘timeout’ => apply_filters( ‘http_request_timeout’, 30), did not work for me.

In the last reply for this issue at http://wordpress.org/support/topic/plugin-api-http-error/page/2, the guy who came up with the solution, said,

"
if you’ve changed that to 30 or 45 or higher number but still get the error, change it to 0. 0 means that no timeout limit.

‘timeout’ => apply_filters( ‘http_request_timeout’, 0),

If by using that way you still get the error, you need to contact your administrator because I think that your server connection is not good.
"

I tried 30, 45, and finally 0 for that timeout parameter, but really no prevail. So, I do think his thought “your server connection is not good” can be reasonable.

Previously, my site which doesn’t have heavy traffics recently suffered numerous disruptions. When contacting the support staff via LivePerson chat, twice, I was told it was because the heavy loads on the server where my VPS is located when either another VPS was being created or other sides was stripping the resources.

So, Scott, do you think, Dreamhost could have restricted some ports or put stingy Firewall restricts on the server where my VPS is on, thus affecting its connection which finally caused the trouble for my self-hosted Wordpress site?


#4

Great! It turned out some a hiccup at the end of my DH hosting end. After submitting a ticket, the talented support staffs solved my problem! Kudos to them!!!