Another upload_max_filesize question


#1

ive followed all the instructions for running the script that installs the cgi-bin folder and php.ini, and i have edited the upload_max_filesize to 100M, and the memory_limit to 191M.

problem is that the memory_limit is working (191M) but the upload_max_filesize is still at a measely 2M (even though i changed it to 100M in php.ini). i have double checked this by uploading a phpinfo file, and it hasn’t changed :frowning:

can anyone help me with this? thanks!


#2

You also need to increase Max Post Size (something like that) to match your 100M upload filesize.


#3

post_max_size is already at 100M. not sure if it should go higher?


#4

They should match. When I’ve had an inconsistency like that, I removed the custom php.ini setup and redid it and it started working with the correct settings. Maybe Fast CGI caches php.ini somewhere. If that’s not it, then perhaps PHP is ignoring that line for some reason.


#5

okay, well ive managed to do nothing besides break my website or have no effects take effect whatsoever.

first, i installed the cgi-bin folder in my domain folder with the script in the wiki. when that didn’t work (after changing the settings in php.ini), i did it manually as per the wiki (multi-domain), which despite my double checking for any errors simply caused my site to stop working entirely, so i removed that and got my server rebooted, and im back at the drawing board.

ive edited php.ini before with no problems on other servers, so im not sure what the problem is. do i need to reboot after editing php.ini? ive tried killing fastcgi and restarting the fastcgi cache (as per the wiki) with no effect.

im using a vps on dreamhost, and i have wordpress installed in the root and vbulletin installed in /community …both have seperate .htaccess files, so im not sure if need to edit both to reference the php.ini in the home cgi-bin folder? either way im not seeing any kind of changes when i put a phpinfo.php file in either the root directory of the domain or /community.

thanks for the help so far, if anyone else could chime in on this id appreciate it.


#6

When I’ve gone the php.ini route, I use sXi’s handy script:
http://sxi.sabrextreme.com/dh-phpini

It’s easier than the manual process I’ve used in the past, and if I’m paying attention, it goes off without a hitch.


#7

sigh, i told you i already tried that. can anyone else chime in on this?


#8

Silly me, I didn’t see mention of which script you actually ran. Good luck!