Another Awstats thread

apps

#1

I’ve tried to look for a solution for this everywhere but without any luck. I installed Awstats fine but the cron doesnt want to work properly. This is the email i recieve everyday at 11:00 GMT.

http://finalfantasy-xiii.net/apps/awstatscron.txt

I dont know if im linking to the wrong file or something because my stat have never updated before

http://finalfantasy-xiii.net/statistics/

I also tried to add an “Update Now” button by changing the conf file as i couldnt get the cron working but that didnt appear. Alot of people have this problem but noones answered that. Can anyone help me out?


#2

What’s your crontab say? Mine looks like so:

0 3 * * * perl /home/username/awstats/tools/awstats_buildstaticpages.pl -config=domain.com -update -awstatsprog=/home/username/awstats/cgi-bin/awstats.pl -dir=/home/username/domain.com/statistics/
I wonder if you’re having this trouble because your path doesn’t seem to start with /home/username?

(I can’t get the instructions for the “Update now” button to work either, not sure exactly what I’m doing wrong.)


#3

Well when i set it up with /home/username it says it cannot find the directory.

This is how my server is layed out:

http://finalfantasy-xiii.net/apps/serverstructure.png

So doesnt that mean i dont need the home/ part of the path?

EDIT: Oh and this is my cron:

perl finalfantasy-xiii.net/finalfantasy-xiii.net/awstats/tools/awstats_buildstaticpages.pl -config=finalfantasy-xiii.net -update -awstatsprog=finalfantasy-xiii.net/finalfantasy-xiii.net/awstats/cgi-bin/awstats.pl -dir=finalfantasy-xiii.net/finalfantasy-xiii.net/finalfantasy-xiii.net.com/statistics/


#4

Please guys, someone has to know what theyre doing. I’ve tried everything :frowning:


#5

Well, for starters, you should always use the full path. That means /home/yourusername/ on the front of all of those directories for your website files, and /usr/local/bin on the front of perl.

/usr/local/bin/perl /home/username/finalfantasy-xiii.net … (and so on).

Try that and see what happens.


#6

This is kind of a stretch as far as my knowledge about installing apps like this, but since nobody else seems to know what the problem is either :slight_smile: I’ll try to help out.

Your directory structure is kinda weird; that threw me off a bit. Is it just that your username and the domain name are the same?

What’s the path to your log file in your awstats.domain.com.conf file? (Mine is LogFile="/home/username/logs/domain.com/http/access.log.0" )

My install does look a lot different from yours. My awstats directory is outside of my webspace, at /home/username/awstats/ I don’t know that installing it where you did should cause any sort of problem, but if it’s still not working after all this time, I wonder if it might be worth a try to remove it altogether and reinstall using either these instructions: http://wiki.dreamhost.com/index.php/AWStats_Installation or these ones: http://wiki.dreamhost.com/index.php/AWStats_Installation_(alternative)

Even if one of those is what you used before, maybe something went wrong during the installation. The first set of instructions is what I used & it got me up and running fairly easily.

Or, an alternative, this post has a link to an awstats package that a user here set up for updating via the browser – I haven’t tried this yet, but maybe it’ll help you out.


Daisy


#7

Thanks alot! :smiley: i tried using my username before hand but i installed it slightly differently than the guide. I thought this time i’d follow the guide to the letter and insert the /home/username path aswell and it works fine now.

Now i want to try and get both my domain and subdomains stats to integrate so they both add up to the total. How could i do this? make the cron point at the subdomains log file aswell somehow?


#8

Hmm. There’s a tool called logresolvemerge.pl, should be in your awstats/tools directory: http://awstats.sourceforge.net/docs/awstats_tools.html#logresolvemerge That might do the trick.


Daisy