Announcement lists and 404 error in Wordpress

wordpress

#1

Hello,

I have just set up my announcement list and if I use the default pages for email confirmation, unregistered, etc, all works fine…

But, when I create a custom page in wordpress and attempt to link it to an announcement list registration action (either via the Dreamhost dashboard or by manually editing the code with the wordpress page url) I get a 404 error.

Can anyone explain what is wrong, and what steps I should take to correct it?

Thanks!


#2

Your post doesn’t have a lot of detail. Are you getting the 404 from your WordPress site, or the Announce List server?

It sounds like you created the signup form in a WordPress page and when you click the Submit button, you’re getting the error. But without seeing your actual page, there’s not much we can help with. It should work, as it’s a pretty basic form submission.


#3

I’m sorry if I was not clear. Obviously I’m not articulating my problem as well as I thought I was.

I have created, in my wordpress site, several pages - a page to be loaded when a person inserts her e-mail for registration in my mailing list; a page to be loaded when the e-mail is confirmed; a page to be loaded when that e-mail already exists in my list; etc.

I have inserted the address of each of those pages in the proper field in the Announce List dashboard, and I have copied the “Announce List registration” html code to the sidebar of my website.

When someone inserts their e-mail, they are not taken to the expected page; instead, they are taken to a 404 error page. And yes, I have double-checked the sintax of the urls that I assigned in the dashboard.
It is worth pointing out that the e-mail adress submission wors fine, I get all registered e-mails; it’s the page that’s supposed to load after you fill in the registration form that does not show up.

Is this any clearer?

Thanks for the help! :)[hr]
Ok, let me see if I can explain better with some visual aides.

This is where it all starts:

http://img832.imageshack.us/img832/7318/vapannounceissue0.jpg

As my e-mail address already exists in the list, it should take me to a page that tells me so, a page that I created on my wordpress blog and associated with this trigger in the Announce List dashboard, like so:

http://img651.imageshack.us/img651/3372/vapannounceissue1.jpg

And the code in my sidebar is like so:

[code]









Nome:

E-mail:

[/code]

(note: I have already tried changing the code directly, IE replacing “http://AlreadyonURL” by the page address; result is the same)

And the result is:

http://imageshack.us/photo/my-images/69/vapannounceissue2.jpg

If I remove the page addresses from the dashboard and just use the Dreamhost defaults, everything looks fine. But they are ugly and not in my language.

Any help would be greatly appreciated. :slight_smile:


#4

The Portuguese(?) is making me dizzy. But a few things:

  1. Every value: http://whatever MUST be valid refer to the Wiki here for help: http://wiki.dreamhost.com/Announcement_Mailing_List
  2. Those URL pages from #1 NEED to exist in WordPress. They’d be a typical “Thank you for subscribing,” “You’re already subscribed,” or “You have been unsubscribed” messages. You create these in WordPress as Create New Page.
  3. The Already Subscribed page you use: removar-assinatura, does it exist in WordPress? The extra parameters after it should be ignored by WordPress. (I just looked at your site and it’s there and properly ignored my test parameter added to the end of the URL.)

#5

2 & 3 I can confirm. All the pages I tried to link to exist in wordpress.

As for 1, no, I did not assign every value to a page, as they were marked as optional I only created and associated the pages I had interest in. I’ll try to create some extra pages and fill up the dashboard form.

Thanks for the suggestions!


#6

There’s a known incompatibility between the query string parameters we pass for Announce List signups and WordPress. You’ll need to set some landing pages that aren’t part of WordPress (e.g, just plain HTML files).


#7

Oh, I see. Well, guess there’s no way around it then, I’ll just have to get busy with the html editor.

Thanks everyone. :slight_smile:


#8

The issue is that Wordpress is parsing the “name” parameter internally. The two fixes are either:

  1. Dreamhost changes the passed parameter to something other than “name”

or

  1. modify your Wordpress config according to this post: http://earthtracker.wordpress.com/2010/11/20/wordpress-name-parameter-in-url-problem-fix/

I’m using option 2 (of course) and haven’t found any issue with the rest of the site because of the change.

-Joe