Allowed to make changes to php.ini?


#1

Do we have shell access to make changes to it?

SicRacing.com


#2

When you create a user through the panel it has an option to allow shell access or not.

You will need to compile php yourself if you want to edit php.ini, check the links below for help if you need it.

Compile PHP4
Compile PHP5


#3

thanks for the help. when using the install script, at the end i ran into some problems with the PHP install itself.

checking lex output file root… ./configure: line 2422: lex: command not found
configure: error: cannot find output from lex; giving up

that’s where the errors start, and it just errors out after that on everything.

lex command not found? what’s going on?


#4

i guess ther server needs lex installed?


#5

My best guess would be that your path is bad.

In your shell type “env” and hit enter(no quotes), look for a line like PATH=/usr/local/bin:/usr/bin:/bin:/usr/bin/X11

If you don’t see /usr/bin in yours do the following command and try your compile again…

export PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/bin/X11:/usr/local/sbin:/usr/local/bin


#6

manic,

I checked env and it shows:

PATH=/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games

After searching on google, other people with this same message were told LEX needed to be on the server.

-Josh

SicRacing.com


#7

so, uhh…anyone else shine some light? i’ve tried to start over and continue to get this error when using that script.

SicRacing.com


#8

if you type in “man lex” at a shell prompt do you get the manual? (type “q” to exit) I can also run lex from shell, but it doesn’t seem to accecpt normal qualifiers, so I can’t determine the version or anything.

So if you can get the man page for lex that means it’s installed on the system and your path is accessing stuff right. If you can’t get the man page, then have you ever edited your .bash_profile file or otherwise edited your path? (I don’t think you have by what you posted above, but just to be sure…)

If you have edited your path, either return it to default or make sure that “:$PATH” follows the last of your change in .bash_profile. Try the install again, does it work now?

If you can’t get the man page and you heavn’t touched your path settings, contact support and ask them to check into why lex isn’t insatlled on your machine.

If you can get the man page, then lex is installed. But you’re abviously still having a problem. Redownload the latest stable version of php5, it’s probably easiest to use wget from the shell (not sure how you did this before) and extract it. It’s possible that you suffered some packet loss or somethign when you downloaded and the files got messed up a tiny bit.

If this doesn’t work, I sigguest seeking help from an ‘official’ php forum and see if people who deal more intimatley with php know what’s going on.

Oh, and one other thing. It seems it’s now called flex, and used to be called lex. not sure if that makes a difference in the world as the man page comes up for lex…

Hope this help, and good luck!

-Matttail


#9

thanks so much for the help. i talked to DH support and i guess lex wasn’t installed. they installed it for me… :slight_smile:

SicRacing.com