Allow_url_fopen problem (arggg)


I’m not a progamer. I can change few thing but consider me as a newbie.

I’m running Article Manager on my web site. One of the feature I have added to it was PHPThumb:

What it does is resizing image on request. It was working perfectly but now that dreamhost have changed the fopen thing, it don’t work any more.

For instruction on how to integrate it in Article Manager, look here (don’T think it will be much help, since phpThumb is more the problem)

If someone could explain me how to solve the problem, I would really apreciate.


I will add some more information about my problem.
Article manager use the variable $img_url$ to call images.
This variable give a full URL (

As far as I understand, because of the allow_url_fopen that is disable, it can’t handle full url (correct me if I’m wrong)

So, what I would need is something that make a new variable using $img_url$, but remove the (so that would give me a relative path, and it should work… if I understand correctly)

As fas as I know, I will not be able to make this in the template file (because it’s a simple html file with no php script)
Maybe using java ?

I would really apreciate help.


I’m using this in a PHP redirection script i wrote:

$path_parts = pathinfo($_SERVER[‘SCRIPT_NAME’]);
$url = “http://”.$_SERVER[‘HTTP_HOST’].$path_parts[‘dirname’] ."/image_name.gif";

$_SERVER is a predefined array, with one of the indexes being SCRIPT_NAME, and another ‘HTTP_HOST’.
you could modify the above code like

$img_url = “$path_parts[‘dirname’] .”/image_name.gif";

hope that was what you were looking for