Allow_url_fopen in php.ini


#1

To check image size and resize with ImageMagic in phpBB 3 RC5, allow_url_fopen must be on in the php.ini-file. Mine says it is set to off. Is there anyway to turn it on?

If not is there a workaround?

TIA,

Bill


#2

The best thing to do would be to change the coding in the plug in or program to use relative paths instead of URLs. Alternativley it could be converted to use curl instead of fopen.

The other solution, though not as good (for security reasons) would be to set up your own PHP.ini settings file and turn url-fopen back on. (link to wiki article)

–Matttail
art.googlies.net - personal website