ADWR app worked w/WEBrick, fails w/Passenger


#1

I’m slavishly cookbooking the AWDR “depot” app, and, four commands into it, I noticed that WEBrick gets killed after about a minute by the procwatch police. So, OK, I set up Passenger. Now my subdomain’s entry point yields a pretty generic RoR welcome screen, but adding my app directory to that results in an utterly blank page. Not an error, nothing in any of the error or production logs, just blank. Adding “products” yields the same result.

http://greenhouse.cloudybrow.com/ >> RoR intro
http://greenhouse.cloudybrow.com/depot/ >> blank
http://greenhouse.cloudybrow.com/depot/products >> blank
http://greenhouse.cloudybrow.com/products >> blank

Using WEBrick,

http://greenhouse.cloudybrow.com/products >> expected web form

I expect this to be a completely stupid bit of minutia that I’ve foolishly overlooked. Has anyone had any success getting the ADWR examples up on DH, or does anyone recognize that symptom (zero-length blank page) as actually meaning something?


#2

I’d like to hear more about this, too. I’m trying to do something similar; deploy an existing small demo Rails app. I’m seeing much the same behavior you describe, with the blank pages.
Can an experienced Rails wizard help us out?