Admin area keeps sending me to 404

wordpress

#1

I have websites using the Wordpress platform. In the past few days, I have started getting errors on at least 2 of the websites. I can log on to the Admin Dashboard, but if I try to update a plugin or view a form entry, it will send me to a 404 error page.

I have reviewed, deactivated, and reactivated my plugins (the websites only share one common plugin). I have refreshed my permalinks. I have checked the .htaccess files. I have checked file permissions.

I know the server is accurately reading php and html files.

AND, if I refresh my browser a few times, the error will eventually get “unstuck” and allow me to go to the task I requested.

It is not happening on the frontend. Only when I am working on the backend.

Any thoughts on where else to look for the issue?


#2

Thank you for posting this. This has been happening to me as well. I’m not happy that it is happening to your sites, but it is comforting that I am not the only one experiencing this.

Previously, my sites have been rock solid. The only major change on my sites has been the addition of Let’s Encrypt, that DreamHost just implemented.

I’ve been trying to track the cause of the 404’s down, but have had no luck.

I have opened a support ticket regarding this, and have yet to hear back.

If I find anything, I will post about it here.

Jim


#3

RECOMMENDATION. DO NOT TURN ON “Let’s Encrypt” WITHOUT PREPARING FOR A DAY OF PAIN. Learn from my experience.

Last night I turned on, “Let’s Encrypt”, which the newsletter touts as a five-minute-make-your-website-secure-two-click-procedure. Consequence, I now have a totally messed-up-formerly-solid-for-months WP VPS site AFTER REVERSING THE CHANGES.

Turning “Let’s Encrypt” off (no changes to the WP files or configuration) in the Dreamhost panel DOES NOT FIX THE PROBLEMS! I am still getting 404 errors all over the place.

Reversing the Dreamhost panel security change—that you’d think would put things back the way they were—somehow screws up the whole site.

I have turned off all my plugins (including my shopping cart among other little things) and am embarked on a pleasant day of Activate-Each-Plugin to figure out how I can get my site back to the functionality it once had. The problem is that the 404’s do not start appearing as soon as a potentially problematic plugin is activated, so it’s not a straightforward process.

Your experience may vary, but I recommend you stay clear of this. I wish I had.

Adrian Segar


#4

It is—if you have a normal html/php/css kind of website. The procedure is a little different for a CMS, however.

WordPress: Did you make sure to change both the WordPress Address and the Site Address in Settings => General? That should do the trick. (See https://make.wordpress.org/support/user-manual/web-publishing/https-for-wordpress/)

MediaWiki: You need to configure $wgServer in your LocalSettings.php file. (You may also need to configure $wgCanonicalServer , depending on how you have configured the former.)

Phorum: Change HTTP Path in Phorum General Settings.


#5

Thanks. Wish Dreamhost had thought to mention that. What is worrying is that reversing the change did not put things back the way they were. I am still narrowing down the plug-in/circumstances that prevent the former WP configuration from working as it did before the change.


#6

It should probably go in the wiki, on a page like http://wiki.dreamhost.com/Configuring_Your_CMS_to_use_an_SSL_Certificate

If someone from DH wants to create that page, I’ll be happy to add the content.


#7

Just FYI—I am still getting the random 404 errors after setting WordPress to use https on all pages. On the bright side, (sarcastic humor) my 404 pages are secure! (/sarcastic humor).

I hope the issue is tracked down soon. My support ticket has been open for two and a half days now with no reply.


#8

Since I still haven’t heard back from the support ticket, I decided to experiment. I went to Setting > Permalinks, I changed it from the custom setting I always use (Post name) to the default (Plain). The 404’s went away, only to be replaced with a 500 server error. This error seems to be as sporadic as the 404 error.

I set Permalinks back to Post name, and the 404 error came back (no 500 error in sight).


#9

Support finally responded with:

…your scripts have been getting automatically killed by our Process Watcher script due to your sites going over memory limits on the shared server.

My sites were fine before Let’s Encrypt, just like @asegar 's comment above. So I opened up another ticket to see if I can get Let’s Encrypt fully removed. This will hopefully bring things back to normal. I’ll come back here and post the results.


#10

So…it seems to be Dreamhost’s reaction to a website going over memory limits? Just kill the scripts?

This makes sense and may keep me from going crazy trying to deactivate and rebuild 2 websites, but now I have to figure out what’s using all the memory…

I will also check the “Let’s Encrypt” options to make sure this is not related.

Thank you for replies, and it is good to know I am not alone in this crazy.


#11

People that are experiencing the 404 errors, I may have tracked down the issue:

In your panel.dreamhost.com > Manage Domains > Edit…

Do you have Extra Web Security? checked on?

If so, uncheck it, and click the Change settings button.

Wait ten minutes or so, and see if the 404 errors go away.

If the 404’s are gone, change that setting on all of your WordPress sites.

•••

Second possibly, if the above doesn’t fix it: On the same page, set PHP Mode to: PHP 5.6 CGI (not FastCGI) — this one may be particularly helpful for sites with a lot of plugins.

Save and wait for ten minutes or so.

Let me know if one or both of the above helps.

Jim


#12

I’ve tried your suggestions and still getting random 404’s in the admin. Any other suggestions? It’s even happening on a clean Wordpress install…


#13

After using the above settings for a few days, I can get a 404 now and then, but it is much better than before.

I don’t know what else to suggest. Perhaps if everyone here opened a support ticket, and referenced this forum thread, DH support might listen better and dig deeper into the issue.


#14

Add me to this list. 404 - randomly, or 500. Never a problem in three years - suddenly all my wordpress sites are unstable. Memory limit was set at 40MB (HUH? That’s NOT ENOUGH for any wordpress site), and even when upping it to 96MB, still errors.

Dreamhost, what have you done???


#15

I’m getting the exact same thing on all of my WordPress websites while working in admin control panel. I try to create a post, update a plugin, do anything and all of the sites redirect to the website and the page says “File Not Found”. It’s wasting so much time having to redo every step twice.

WHY IS THIS HAPPENING?

I don’t have Let’s Encrypt on any of them. I’ve also turned off all plugins and it still occurs. I’ve made no significant changes to any of the websites and all the ones I have checked are doing this.


#16

I’m in the same boat. Never had any problems and now suddenly I’m getting random 404 and 505 errors when saving a post, updating a plugin, etc…

The error.log file is full of the following lines:

[Fri Feb 19 01:02:55 2016] [error] [client x.x.x.x] Premature end of script headers: wp-cron.php
[Fri Feb 19 01:05:36 2016] [error] [client x.x.x.x] Premature end of script headers: index.php

I’ve increased the memory limit to 512M with no success.

Any ideas?


#17

Nothing we can do will fix this - they’ve got major issues and i wonder how long it will take before they address them. I just visited one of my sites, not logged on, and it loaded the header and died. A nice big blank page that’ll randomly server to an unsuspecting visitor.

Reload… all is fine. Memory limit is set high enough. Encoding off. Security not on.

Wakeup dreamhost.


#18

This can be caused by a lot of things. Try turning on wp_debug in your WordPress config file and check if anything turns up. This behavior may be caused by a misbehaving plugin.


#19

DH checked my site and told me to deactivate all of my plugins to fix the problem. Sorry, but that’s not a solution. These plugins have worked fine for years. This is occurring on multiple unrelated Wordpress websites on my account. It doesn’t seem plugin or website related, seems more like a hosting issue.


#20

Tried turning the WP_DEBUG var on, but I can’t see anything suspicious.