Adding www (redirect) when using Google Apps


#1

I have this domain where I’m using Google Apps. The “Google Sites” service is set to use http://www.mydomain.com (I have only one site in Google Sites)

How can I make dreamhost redirect http://mydomain.com -> to -> http://www.mydomain.com ?

Right now if you go to the domain without www Google responds with a 404.

I tried using the options labeled “Do you want the www in your URL?” in the Manage Domains section of the panel but that doesn’t work. Is there any other way?

Thanks for your help!


#2

Only thing that I’ve found to work so far is the meta redirect, which I hate to use for SEO and google-bot citizenship reasons.

Google help forum http://www.google.com/support/forum/p/Google+Apps/thread?tid=7dd4cd04d7a2bf70&hl=en&fid=7dd4cd04d7a2bf7000048911d67918c9 and Knol http://knol.google.com/k/google-apps-discussion-group#

Really, the fix should come from the ghs side; but until then, here we are.


#3

Thanks a lot silverton! I’m looking into it now.


#4

do you mean using redirect in Manage Domains -> Redirect and setting the Redirect to URL to www.domain.com?


#5

Hi frntk,

Did you ever get a solution to your problem? Because I just hit the exact same problem and I haven’t found a way around it yet. I’d be very curious what you ended up doing.

To restate: Google Sites will let you set up a “URL mapping” for any name within the domain you’re hosting, to point to a specific place in Google Sites. So if you’re hosting “foo.com” in Google Apps, you could make “http://www.foo.com/” point to a specific “site” in Google Sites. (assuming you have the proper DNS records set up). But – and this is a limitation of Google Sites, not of Dreamhost – you cannot make “http://foo.com/” point anywhere in Google Sites.

I tried, in Dreamhost, putting redirect-style hosting on “foo.com” and setting it to redirect to “http://www.foo.com/”, but that tried to insert a DNS record for www.foo.com, as well, which clashes with the CNAME to ghs.google.com. We need a way to redirect only foo.com, and leave www.foo.com as a CNAME to google.

Thanks!!


#6

I ended up with a meta redirect as silverton suggested. The options from the panel (including the redirect) don’t work for this.

Hope that helps!