Adding SSI support causes mod_dir “trailing slash” redirect to stop working


#1

I recently shifted from dreamhost shared hosting to dreamhost ps. Since I have shifted to dreamhost ps, mod_include and mod_dir don’t seem to be playing well together.

I have enabled SSI using the following directives in .htaccess

AddHandler server-parsed .html 
AddOutputFilter INCLUDES html

However when I add these, the trailing slash redirects stop working.

For eg. http://testwp.humbug.in/test/index.html works fine

but

http://testwp.humbug.in/test/ doesn’t work.

In chrome it gives a “Error 324 (net::ERR_EMPTY_RESPONSE)” error while in firefox it shows a blank page.

What additional configuration do I need for both mod_dir and mod_include to work properly?

P.S. Did not have this problem when using shared hosting.

Same files on shared hosting:

http://gems.humbug.in/test/ and http://gems.humbug.in/test/index.html both work with the above directives enabled.


#2

Taking a guess: Try specifying the RemoveOutputFilter directive first? I’m thinking the problem might be output having gone through DEFLATE (gzip) already.


#3

Great! That worked!


#4

Actually the SSI stopped working completely if I add RemoveOutputFilter, noticed that just now, any other clues?

[code]

RemoveOutputFilter html
AddOutputFilter INCLUDES html[/code]

Is this how the configuration should look like?