Adding Media Files in Wordpress fails

wordpress

#1

Since yesterday, I can’t upload media files (images) within Wordpress anymore. When I write my post, and then use the built-in file uploader in Wordpress to upload an image, it complains with the following error message:

Unable to create directory /home/.furball/myusername/mydomain.com/wp-content/uploads/2009/11. Is its parent directory writable by the server?

The problem occurred right after my domain was moved to a new machine (addisababa), so I believe Wordpress is still looking to save it on furball, which I believe is the problem. Is there a way to tell Wordpress that the new path is /home/.addisababa/…? Or do you know any other solution? I upgraded Wordpress to the latest version thinking that would fix it, but it didn’t.

Thanks for any help!


#2

If you open up wp-config.php in your domain’s directory, you should see the path listed there. Remove .firball/ from it. And then, just for good measure, read this Wiki article.

I used to have a website here. For reasons, I no longer do.


#3

Same thing happened to me. Log into wp-admin and click on Settings -> Miscellaneous and change the upload path to the default of wp-content/uploads

-Scott


#4

Thanks Scott and quanin, that fixed it!