Activate CDN with a third party domain name

dreamobjects

#1

Hi,

I have already a registered domain name with another registrar and I would like to use that as an alias instead of bucket.objects-us-west-1.dream.io

I’ve found this post but doesn’t give any detail how to do that :

Thank you in advance!


#2

Follow all those instructions, then duplicate that CNAME entry that shows up in your DreamHost DNS over to your current DNS.

For example, I use CloudFlare DNS. At CloudFlare, I added a CNAME entry for “cdnbucket” that points to mybucket.objects.cdn.dream.io


#3

Hi sdayman,

I went to my registrar and I added a new CNAME record like you told me, I named it “cdnbucket” and the target to “my_own_backet.cdn.dream.io” ( by the way, shouldn’t be “my_own_bucket.objects-us-west-1.dream.io” instead ?)

but how it can be show up in the dropdown of my bucket ?


#4

Funny you should mention the us-west part of the URL. It says it in the instructions, but that’s not’s in my DreamHost DNS. I actually copy and pasted the actual CNAME record and it does work. It’s also what’s displayed in CDN settings window.

Have you completed all the steps of the instruction page? Click settings…turn on CDN Support at the bottom…Create the alias and turn on its CDN?


#5

I’ve just turned on the CDN support at the bottom then it showed me “my_own_bucket.objects.cdn.dream.io” which seems to be the right url to use, and I went back to my DNS provider and I re-enter “my_own_bucket.objects.cdn.dream.io” just to make sure everything is ok.

That’s all what I did so far. now if I go to my bucket settings -> Aliases I can put a subdomain but the dropdown menu still empty ! so I am not able to choose a domain!

In the documentation there is a note saying : “If you’re using a third-party DNS, be sure to manually copy the CNAME from the panel to the name servers since it won’t automatically propagate.” I am not sure what does this mean exactly! maybe I should do something to make the dropdown recognize my domain name ?


#6

Ohhhh…is that domain hosted here? If not, you’ll have to fake it:

  1. Go to Manage Domains
  2. Click at the top for Add Hosting to a Sub/Domain
  3. Scroll WAY to the bottom for for DNS Only
  4. Enter your outside hosted domain and click DNS Only.

Now you should be able to add an alias for that domain.


#7

Yeah it works! Thank you! will I be able to use that new alias as url to POST (upload) images ? and to save it as the main url for my images

Actually the POST request is sent to https://my_own_backet.objects-us-west-1.dream.io and the image url looks like this https://my_own_backet.objects-us-west-1.dream.io/uploads/Es3r631y3T/file.jpg